summaryrefslogtreecommitdiff
path: root/www
AgeCommit message (Collapse)Author
2024-01-21Implement input sanitationmuseum-first-oop-elispMarek Paśnikowski
To the best of my current ability, implement checks and guards on the given inputs.
2024-01-20Abstract away the user logic from the user interfaceMarek Paśnikowski
2024-01-20Annotate sections of the publishing codeMarek Paśnikowski
Divide the file into sections representing different abstraction layers of the package.
2024-01-20Fix name convention of the project getterMarek Paśnikowski
Unify the naming convention of the project getter function to mirror the :object-get-projects method.
2024-01-20Fix misunderstood instancing of publishing-objectMarek Paśnikowski
The recently introduced test suite uncovered a fatal error in my understanding of how to correctly manage instances of objects.
2024-01-20Separate testing facility in a new fileMarek Paśnikowski
Pull out and expand the testing code into a dedicated file. Also, remove the requirement on 'ox-publish because this package is not yet used at all.
2024-01-20Implement composition of org-publish-project-alistMarek Paśnikowski
The current object implementation is able to compose a list of project names into =org-publish-project-alist= . Yet to be implemented are the property parser, as well as the components parser.
2024-01-20Complete the initial implementation of the publishing object.Marek Paśnikowski
This marks the end of experimentation with OOP in elisp. From now the actual implementation of publishing system begins.
2024-01-19Learn to use "named" lambdas in closures.Marek Paśnikowski
Rewrite the builder code with use of a property list.
2024-01-19Create proper object for the builderMarek Paśnikowski
It turned out I had not constructed a real closure before. I also decided to explicitly return nil for future code expansions.
2024-01-19Fix a typo in build-siteMarek Paśnikowski
A letter 'y' was missing in the word property at the end of the line.
2024-01-18Create initial build object.Marek Paśnikowski
The code is more complex than necessary, because of my insistence of creating an all-object oriented framework.