summaryrefslogtreecommitdiff
path: root/packages/komodo/komodo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'packages/komodo/komodo.scm')
-rw-r--r--packages/komodo/komodo.scm17
1 files changed, 15 insertions, 2 deletions
diff --git a/packages/komodo/komodo.scm b/packages/komodo/komodo.scm
index fff8c09..c074f7b 100644
--- a/packages/komodo/komodo.scm
+++ b/packages/komodo/komodo.scm
@@ -29,6 +29,7 @@
#:prefix license:)
#:use-module (guix packages)
#:use-module (refl-cpp)
+ #:use-module (sortfilterproxymodel)
#:use-module (strong-type)
#:use-module (taskflow-2))
@@ -266,6 +267,17 @@
(("STD")
"STD\n#include <nlohmann/json.hpp>")))
+(define link-libraries
+ `(substitute* "cmake/dependencies.cmake"
+ (("ALIAS refl-cpp\\)")
+ (string-append "ALIAS refl-cpp)\n"
+ "add_library(strong_type INTERFACE)\n"
+ "target_link_libraries(strong_type INTERFACE strong_type)\n"
+ "add_library(doom_meta INTERFACE)\n"
+ "target_link_libraries(doom_meta INTERFACE doom_meta)\n"
+ "add_library(SortFilterProxyModel INTERFACE)\n"
+ "target_link_libraries(SortFilterProxyModel INTERFACE SortFilterProxyModel)\n"))))
+
(define remove-unity
`(substitute* "src/CMakeLists.txt"
(("UNITY_BUILD ON")
@@ -289,7 +301,8 @@
,fix-date
,fix-doom-meta
;; ,remove-unity
- ,include-nlohmann))
+ ,include-nlohmann
+ ,link-libraries))
(define entt-komodo-content-hash-get
(content-hash (base32 entt-komodo-hash)))
@@ -426,7 +439,7 @@
(list boost cpprestsdk date doctest doom-meta entt-komodo fmt git
libsodium-komodo nlohmann-json openssl perl python qtcharts
qtdeclarative-5 qttools-5 qtsvg-5 qtwebengine-5 range-v3 refl-cpp
- spdlog-1.8 strong-type taskflow-2 wally zlib))
+ sortfilterproxymodel spdlog-1.8 strong-type taskflow-2 wally zlib))
(define komodo-wallet-synopsis
(string-concatenate komodo-wallet-synopsis-lines))