summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-31 04:19:08 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:53:58 +0200
commit0639d6fc86a2f1ffe45d9af8eb0f7b98421eec2d (patch)
tree8b6d7c632debdd617468fa269ebeea5962a89d46
parent5234760dea299714a5dd3ae062e4002e15324fe0 (diff)
gnu: emacs-shut-up: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-shut-up)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4ba0538669..89459f82be 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2313,13 +2313,13 @@ IRC bouncer with ERC.")
(version "0.3.2")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/cask/shut-up/"
- "archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cask/shut-up.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "09kzrjdkb569iviyg7ydwq44yh84m3f9hkl7jizfrlk0w4gz67d1"))))
+ (base32 "103yvfgkj78i4bnv1fwk76izsa8h4wyj3vwj1vq7xggj607hkxzq"))))
(build-system emacs-build-system)
(home-page "https://github.com/cask/shut-up")
(synopsis "Silence Emacs")