summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Paśnikowski <marek@marekpasnikowski.pl>2024-03-19 10:39:07 +0100
committerMarek Paśnikowski <marek@marekpasnikowski.pl>2024-03-19 11:32:07 +0100
commit10870e680aeeb2ef55d6630bef7d949e8a69315d (patch)
treeef04923ab57f96bf2f87ad45c1aadf116b056951
parent5c9840d4f87b9ac919649c14d986b9a8f7c1935e (diff)
Prepare new indentation level for let statements
-rw-r--r--private/komodo/komodo.scm118
1 files changed, 59 insertions, 59 deletions
diff --git a/private/komodo/komodo.scm b/private/komodo/komodo.scm
index 811494d5aa..e7cd877ad7 100644
--- a/private/komodo/komodo.scm
+++ b/private/komodo/komodo.scm
@@ -55,68 +55,68 @@
"https://github.com/KomodoPlatform/komodo-wallet-desktop")
(commit version)))
(komodo-wallet-hash (content-hash "0pfkgas0xkixf99zqzyri80ksp89b7dw7hbcgpp60ni2cnchxk2n"))
- (phases #~ (modify-phases
- %standard-phases
- (add-after
- 'unpack
- 'delete-vcpkg
- (lambda _
- (substitute*
- "CMakeLists.txt"
- (("include\\(vcpkg_prerequisites\\)")
- (string-append
- "\nfile(MAKE_DIRECTORY \"" #+ build-path-expected "\")\n"
- "file(MAKE_DIRECTORY \"" #+ build-path-jl777-coins "\")\n"
- "file(MAKE_DIRECTORY \"" #+ build-path-mm2 "\")\n"
- "file(COPY "
- #+ (origin
- (uri
- (git-reference
- (url
- "https://github.com/TartanLlama/expected")
- (commit "v1.1.0")
- (recursive? #t)))
- (method git-fetch)
- (hash
- (content-hash
- "17akrv80h0n4cfmxwvlvbb8ycqza7y3qqygjyphv95rrabqm9r02"))
- (file-name (git-file-name "libexpected" "1.1.0"))
- (patches
- (search-patches "libexpected-use-provided-catch2.patch")))
- "/ " " DESTINATION " #+ build-path-expected
- " NO_SOURCE_PERMISSIONS"
- " FOLLOW_SYMLINK_CHAIN)\n"
- "file(ARCHIVE_EXTRACT INPUT "
- #+ (origin
- (uri "https://github.com/KomodoPlatform/coins/archive/master.zip")
- (method url-fetch)
- (hash
- (content-hash
- "1icbd6f8nridzc93vz7hsr5dnkrf328zfsw6rrzifc7nvsr559w8")))
- " DESTINATION " #+ build-path-jl777-coins " )\n"
- "file(COPY " #+ build-path-jl777-coins "/coins-master/ "
- "DESTINATION " #+ build-path-jl777-coins ")\n"
- "file(ARCHIVE_EXTRACT INPUT "
- #+ (origin
- (uri
- "https://sdk.devbuilds.komodo.earth/main/mm2_b0fd99e-linux-x86-64.zip")
- (method url-fetch)
- (hash
- (content-hash
- "1bn2sjcrp9ih44h3p96prnwg74aids7fgzcnlv3c68nan6y2lysi")))
- " DESTINATION " #+ build-path-mm2 " )\n"))))))))
+ (phases #~ (let ()
+ (modify-phases %standard-phases
+ (add-after 'unpack
+ 'delete-vcpkg
+ (lambda _
+ (substitute*
+ "CMakeLists.txt"
+ (("include\\(vcpkg_prerequisites\\)")
+ (string-append
+ "\nfile(MAKE_DIRECTORY \"" #+ build-path-expected "\")\n"
+ "file(MAKE_DIRECTORY \"" #+ build-path-jl777-coins "\")\n"
+ "file(MAKE_DIRECTORY \"" #+ build-path-mm2 "\")\n"
+ "file(COPY "
+ #+ (origin
+ (uri
+ (git-reference
+ (url
+ "https://github.com/TartanLlama/expected")
+ (commit "v1.1.0")
+ (recursive? #t)))
+ (method git-fetch)
+ (hash
+ (content-hash
+ "17akrv80h0n4cfmxwvlvbb8ycqza7y3qqygjyphv95rrabqm9r02"))
+ (file-name (git-file-name "libexpected" "1.1.0"))
+ (patches
+ (search-patches "libexpected-use-provided-catch2.patch")))
+ "/ " " DESTINATION " #+ build-path-expected
+ " NO_SOURCE_PERMISSIONS"
+ " FOLLOW_SYMLINK_CHAIN)\n"
+ "file(ARCHIVE_EXTRACT INPUT "
+ #+ (origin
+ (uri "https://github.com/KomodoPlatform/coins/archive/master.zip")
+ (method url-fetch)
+ (hash
+ (content-hash
+ "1icbd6f8nridzc93vz7hsr5dnkrf328zfsw6rrzifc7nvsr559w8")))
+ " DESTINATION " #+ build-path-jl777-coins " )\n"
+ "file(COPY " #+ build-path-jl777-coins "/coins-master/ "
+ "DESTINATION " #+ build-path-jl777-coins ")\n"
+ "file(ARCHIVE_EXTRACT INPUT "
+ #+ (origin
+ (uri
+ "https://sdk.devbuilds.komodo.earth/main/mm2_b0fd99e-linux-x86-64.zip")
+ (method url-fetch)
+ (hash
+ (content-hash
+ "1bn2sjcrp9ih44h3p96prnwg74aids7fgzcnlv3c68nan6y2lysi")))
+ " DESTINATION " #+ build-path-mm2 " )\n")))))))))
(let ((arguments (list #:phases phases
#:configure-flags configure-flags))
- (description (string-append "Komodo Wallet is a secure wallet and "
- "non-custodial decentralized exchange "
- "rolled into one application. Store "
- "your coins, trade peer-to-peer with "
- "minimal fees and never give up "
- "control over your digital assets."))
+ (description (string-append "Komodo Wallet is a secure wallet "
+ "and non-custodial decentralized "
+ "exchange rolled into one "
+ "application. Store your coins, "
+ "trade peer-to-peer with minimal "
+ "fees and never give up control over "
+ "your digital assets."))
(native-inputs (list boost cpprestsdk date doctest entt fmt git
- libsodium-komodo nlohmann-json openssl qtcharts
- qtdeclarative-5 qttools-5 qtsvg-5 qtwebengine-5
- range-v3 spdlog zlib))
+ libsodium-komodo nlohmann-json openssl
+ qtcharts qtdeclarative-5 qttools-5 qtsvg-5
+ qtwebengine-5 range-v3 spdlog zlib))
(komodo-wallet-origin (origin (uri komodo-wallet-git-reference)
(method git-fetch)
(hash komodo-wallet-hash))))