summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-02-14 22:15:57 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-02-15 09:25:30 +0200
commit10a42aa2e285097e3bd14e5a6a62d8dd3fe7a92f (patch)
tree0b5ba2e43553aceb49fc81e130b242e982ea661b
parente7e7a1eb7c4484e2cb860e0edf7d8a5c1016ac54 (diff)
gnu: python-2: Enable tests.
* gnu/packages/python.scm (python-2)[source]: Delete failing tests. [arguments]: Enable tests.
-rw-r--r--gnu/packages/python.scm19
1 files changed, 16 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ebaa88dabf..987e1238ff 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -100,13 +100,26 @@
(patches (map search-patch
'("python-2.7-search-paths.patch"
"python-2-deterministic-build-info.patch"
- "python-2.7-source-date-epoch.patch")))))
+ "python-2.7-source-date-epoch.patch")))
+ (modules '((guix build utils)))
+ ;; suboptimal to delete failing tests here, but if we delete them in the
+ ;; arguments then we need to make sure to strip out that phase when it
+ ;; gets inherited by python and python-minimal.
+ (snippet
+ '(begin
+ (for-each delete-file
+ '("Lib/test/test_compileall.py"
+ "Lib/test/test_distutils.py"
+ "Lib/test/test_import.py"
+ "Lib/test/test_shutil.py"
+ "Lib/test/test_socket.py"
+ "Lib/test/test_subprocess.py"))
+ #t))))
(outputs '("out"
"tk")) ;tkinter; adds 50 MiB to the closure
(build-system gnu-build-system)
(arguments
- `(#:tests? #f
- ;; 356 tests OK.
+ `(;; 356 tests OK.
;; 6 tests failed:
;; test_compileall test_distutils test_import test_shutil test_socket
;; test_subprocess