summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 13:02:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 17:03:11 +0200
commit10ae76b1327bcabe47b714e3fe3cc04fbd35cc6c (patch)
treeb48466f15a0bc37aad666f264ab100a7d63bca6f
parent8d6e8c703dd90911ae5329c3cb4d2cc84d375b14 (diff)
gnu: Add texlive-amstex.
* gnu/packages/tex.scm (texlive-amstex): New variable.
-rw-r--r--gnu/packages/tex.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bd3e9d725a..a9159eb613 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1450,6 +1450,44 @@ geometry remains. This nevertheless allows the drawing of a much broader
class of commutative diagrams and alike.")
(license license:lppl1.3c)))
+(define-public texlive-amstex
+ (package
+ (name "texlive-amstex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/amstex/base/" "doc/man/man1/amstex.1"
+ "doc/man/man1/amstex.man1.pdf"
+ "tex/amstex/base/" "tex/amstex/config/")
+ (base32
+ "01yh10g2wwa58q151aqg246bsclks25qvd8axc1v799v37wlgqn3")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:create-formats #~(list "amstex")))
+ (propagated-inputs
+ (list texlive-amsfonts
+ texlive-cm
+ texlive-hyphen-base
+ texlive-knuth-lib
+ texlive-plain
+ texlive-tex))
+ (home-page "https://ctan.org/pkg/amstex")
+ (synopsis "American Mathematical Society plain TeX macros")
+ (description
+ "AMS-TeX is a TeX macro package based on Plain TeX: it provides many
+features for producing more professional-looking maths formulas with less
+burden on authors.
+
+This is the final archival distribution of AMS-TeX. AMS-TeX is no longer
+supported by the AMS, nor is it used by the AMS publishing program. The AMS
+does not recommend creating any new documents using AMS-TeX; this distribution
+will be left on CTAN to facilitate processing of legacy documents and as
+a historical record of a pioneering TeX macro collection that played a key
+role in popularizing TeX and revolutionizing mathematics publishing. AMS-TeX
+is the historical basis of @code{amslatex}, which should now be used to
+prepare submissions for the AMS.")
+ (license license:lppl)))
+
(define-public texlive-apnum
(package
(name "texlive-apnum")