summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Lechner <felix.lechner@lease-up.com>2023-05-15 11:19:05 -0700
committerHilton Chain <hako@ultrarare.space>2023-08-24 12:44:46 +0800
commit160f78a4d92205df986ed9efcce7d3aac188cb24 (patch)
tree4f786b6f7978827a93501b7d7193eeb8ea1f5c48
parent63b2d9a8f1c5251d72d44a36929b0cdf19533971 (diff)
gnu: lsscsi: Move to (gnu packages scsi).
* gnu/packages/linux.scm (lsscsi): Move to... * gnu/packages/scsi.scm (lsscsi): ... here. (sg3-utils)[license]: Use license: prefix. (libiscsi)[license]: Likewise. Signed-off-by: Hilton Chain <hako@ultrarare.space>
-rw-r--r--gnu/packages/linux.scm21
-rw-r--r--gnu/packages/scsi.scm30
2 files changed, 25 insertions, 26 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index cc6865f0c6..ca223aea37 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3122,27 +3122,6 @@ early boot when entropy may be low, especially in virtualised environments.")
(license (list license:bsd-3 ; or
license:gpl2+))))
-(define-public lsscsi
- (package
- (name "lsscsi")
- (version "0.32")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "http://sg.danny.cz/scsi/lsscsi-" version ".tar.xz"))
- (sha256
- (base32
- "0jp458m2b3wckr18qkln69i01152qlwz33zm49103lq8fgx0n6d4"))))
- (build-system gnu-build-system)
- (synopsis "Lists information about SCSI or NVMe devices in Linux")
- (home-page "https://sg.danny.cz/scsi/lsscsi.html")
- (description
- "@command{lsscsi} lists SCSI logical units or SCSI targets. It can
-also list NVMe namespaces or controllers and show the relationship between a
-device's primary node name, its SCSI generic (sg) node name and its kernel
-name.")
- (license license:gpl2)))
-
(define-public ebtables
(package
(name "ebtables")
diff --git a/gnu/packages/scsi.scm b/gnu/packages/scsi.scm
index 6e52e3aaa5..08ccedb500 100644
--- a/gnu/packages/scsi.scm
+++ b/gnu/packages/scsi.scm
@@ -19,8 +19,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages scsi)
- #:use-module ((guix licenses)
- #:select (gpl2+ bsd-2 bsd-3 lgpl2.1+))
+ #:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -70,7 +69,7 @@ used in C and C++ programs to interact with SCSI devices.")
;; "3 clause" to the newer "2 clause" version on 20180119. To save space
;; various source code files refer to a file called "BSD_LICENSE" [...]."
;; Some files (like sg_compare_and_write.c) retain their 3-clause headers!
- (license (list gpl2+ bsd-2 bsd-3))))
+ (license (list license:gpl2+ license:bsd-2 license:bsd-3))))
(define-public libiscsi
(package
@@ -97,6 +96,27 @@ synchronous layer is also provided for ease of use for simpler applications.")
(license (list
;; For the src, examples and test-tool directories, except
;; src/ld_iscsi.c.
- gpl2+
+ license:gpl2+
;; For the lib and include directories.
- lgpl2.1+))))
+ license:lgpl2.1+))))
+
+(define-public lsscsi
+ (package
+ (name "lsscsi")
+ (version "0.32")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://sg.danny.cz/scsi/lsscsi-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0jp458m2b3wckr18qkln69i01152qlwz33zm49103lq8fgx0n6d4"))))
+ (build-system gnu-build-system)
+ (synopsis "Lists information about SCSI or NVMe devices in Linux")
+ (home-page "https://sg.danny.cz/scsi/lsscsi.html")
+ (description
+ "@command{lsscsi} lists SCSI logical units or SCSI targets. It can
+also list NVMe namespaces or controllers and show the relationship between a
+device's primary node name, its SCSI generic (sg) node name and its kernel
+name.")
+ (license license:gpl2)))