summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:30:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:59 +0200
commit44467b26fd1214bea857ab61f36ffc28b655fd7d (patch)
tree4429d0b1ce60c44dd4da41e3273a039ad6bf2eb6
parent793b25629758b6073e317b4ac99205f7ee7a1a02 (diff)
gnu: Add texlive-quantumarticle.
* gnu/packages/tex.scm (texlive-quantumarticle): New variable.
-rw-r--r--gnu/packages/tex.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 02282f26dc..c46c477deb 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -25857,6 +25857,37 @@ end.")
"This is a collection of 45 fonts, created by QualiType.")
(license (list license:silofl1.1 license:gpl2+))))
+(define-public texlive-quantumarticle
+ (package
+ (name "texlive-quantumarticle")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "bibtex/bst/quantumarticle/"
+ "doc/latex/quantumarticle/"
+ "tex/latex/quantumarticle/")
+ (base32
+ "00v04n109mbi7w0xcmfdzs8f1fabwd2qhf53fqps99k3dj4z5f0a")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/quantumarticle")
+ (synopsis "Document class for submissions to the @emph{Quantum} journal")
+ (description
+ "This package provides the preferred document class for papers to be
+submitted to @emph{Quantum --- the open journal of quantum science}. It is
+based on the @code{article} document class.
+
+As a service to authors, the document class comes with a predefined
+bibliography style @file{quantum.bst} that is optimized to be used with the
+@code{quantumarticle} document class. Additionally, the @code{quantumview}
+document class is provided, which can be used as a proxy to typeset the
+HTML-only editorial pieces in @emph{Quantum Views}.
+
+The @code{quantumarticle} document class also offers an option to remove the
+@emph{Quantum}-related branding. In that way, users can use it for their
+notes as well.")
+ (license license:lppl1.3c)))
+
(define-public texlive-quattrocento
(package
(name "texlive-quattrocento")