summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 13:08:27 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:14 +0200
commit4455e2352ab0d747c1eaae93de10b1c2d4600e62 (patch)
tree1db19b2caa8f46c688b21ffee1f732ab2bf0ee16
parenta0a1840febc1cccbea1b244204a9a48a09959789 (diff)
gnu: Add texlive-bytefield.
* gnu/packages/tex.scm (texlive-bytefield): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0ea8296df6..d2010b6577 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2019,6 +2019,28 @@ alternate form.")
entire (sub)deductions.")
(license license:lppl1.3c)))
+(define-public texlive-bytefield
+ (package
+ (name "texlive-bytefield")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/bytefield/"
+ "source/latex/bytefield/"
+ "tex/latex/bytefield/")
+ (base32
+ "0sijllb1nmg7alp8kma9gg2cl591p6vjs488yndpbjg49ih2bx71")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/bytefield")
+ (synopsis "Create illustrations for network protocol specifications")
+ (description
+ "The @code{bytefield} package helps the user create illustrations for
+network protocol specifications and anything else that utilizes fields of
+data. These illustrations show how the bits and bytes are laid out in
+a packet or in memory.")
+ (license license:lppl1.3a)))
+
(define-public texlive-c-pascal
(package
(name "texlive-c-pascal")