summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 21:06:14 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit45882aafcb283d1e3ca6caf5e9df410db9f0ab62 (patch)
tree3f798a1fb2ec57c4c665ea5eaab72a3dd8ee3847
parentdaf5cd28dc562a1abea9f267231c787bbfeb935e (diff)
gnu: Add ghc-hspec-meta.
* gnu/packages/haskell.scm (ghc-hspec-meta): New variable.
-rw-r--r--gnu/packages/haskell.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index df5c82b2fd..aff6931ea0 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1448,6 +1448,36 @@ responses coming back.")
be used to extend Hspec's functionality.")
(license expat)))
+(define-public ghc-hspec-meta
+ (package
+ (name "ghc-hspec-meta")
+ (version "2.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/hspec-meta/hspec-meta-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1fmqmgrzp135cxhmxxbaswkk4bqbpgfml00cmcz0d39n11vzpa5z"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-ansi-terminal" ,ghc-ansi-terminal)
+ ("ghc-async" ,ghc-async)
+ ("ghc-hspec-expectations" ,ghc-hspec-expectations)
+ ("ghc-setenv" ,ghc-setenv)
+ ("ghc-random" ,ghc-random)
+ ("ghc-quickcheck-io" ,ghc-quickcheck-io)))
+ (home-page "http://hspec.github.io/")
+ (synopsis "Version of Hspec to test Hspec itself")
+ (description "This library provides a stable version of Hspec which is
+used to test the in-development version of Hspec.")
+ (license expat)))
+
(define-public ghc-async
(package
(name "ghc-async")