summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-05 04:17:08 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:04 +0200
commit45c6a66414e64fde23f9ed0e4343e8b375302227 (patch)
treecb392ea55e07c70d723f3851203de1d313ea2b0b
parentd95ec770db23fceda3237c55bca767ee4a54d10c (diff)
gnu: emacs-pkg-info: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-pkg-info)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/emacs-xyz.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5e51743a5c..4348b38225 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4455,15 +4455,15 @@ be removed from the front. This type of data structure is sometimes called an
(package
(name "emacs-pkg-info")
(version "0.6")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/lunaryorn/pkg-info.el/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1gy1jks5mmm02gg1c8gcyr4f8a9s5ggzhk56gv33b9mzjqzi5rd5"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lunaryorn/pkg-info.el.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0nk12dcppdyhav6m6yf7abpywyd7amxd4237zsfd32w4zxsx39k1"))))
(build-system emacs-build-system)
(propagated-inputs `(("emacs-epl" ,emacs-epl)))
(home-page "https://github.com/lunaryorn/pkg-info.el")