summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-20 21:35:57 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 00:20:36 -0400
commit50c8db7f6098993eb1160cb4fba9512dfe38cc89 (patch)
tree0c7fee2b49107cd44407c4baee5b38c99b645961
parent603a8e729e3bbaa8d2bee82755a8a67608966b5e (diff)
gnu: gdm: Patch dbus-run-session path.
* gnu/packages/gnome.scm (gdm)[phases]{patch-paths}: New phase. [inputs]: Add dbus.
-rw-r--r--gnu/packages/gnome.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e3474e4215..6e971f33c7 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8434,6 +8434,11 @@ library.")
"--sbindir" (string-append #$output "/bin"))
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "daemon/gdm-session.c"
+ (("dbus-run-session")
+ (search-input-file inputs "bin/dbus-run-session")))))
(add-before 'configure 'pre-configure
(lambda* (#:key inputs #:allow-other-keys)
;; We don't have <systemd/sd-daemon.h>.
@@ -8574,6 +8579,7 @@ logo='~a'~%" icon))))))
(inputs
(list accountsservice
check ;for testing
+ dbus
elogind
eudev
gnome-session