summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:08 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:26 +0200
commit64a042401d03773709a318a48f779b1f64ca2b4e (patch)
tree641a385c33ca0a393ab382c73efb617acb5cb146
parenta49c35d29bbbf6d882c3cc922ac88f854c87f8c8 (diff)
gnu: Add trytond-account-payment-stripe.
* gnu/packages/tryton.scm (trytond-account-payment-stripe): New variable.
-rw-r--r--gnu/packages/tryton.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 282d1cbc51..09c3e57f02 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -915,6 +915,33 @@ generate SEPA files for a Payment Group.")
CFONB flavors to SEPA messages.")
(license license:gpl3+)))
+(define-public trytond-account-payment-stripe
+ (package
+ (name "trytond-account-payment-stripe")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_account_payment_stripe" version))
+ (sha256
+ (base32 "18hr2lrrx9asb0d3cjcpska4bv825yjln9cbqjzg0xbl36z6w3s2"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "account_payment_stripe"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("python-stripe" ,python-stripe)
+ ("trytond" ,trytond)
+ ("trytond-account" ,trytond-account)
+ ("trytond-account-payment" ,trytond-account-payment)
+ ("trytond-party" ,trytond-party)))
+ (home-page
+ "https://docs.tryton.org/projects/modules-account-payment-stripe")
+ (synopsis "Tryton module for Stripe payment")
+ (description "The @emph{Account Payment Stripe} Tryton module for
+receiving payments from Stripe. It uses Stripe.js and Stripe Elements in a
+checkout form to handle Setup Intent and Payment Intent by card.")
+ (license license:gpl3+)))
+
(define-public trytond-account-product
(package
(name "trytond-account-product")