summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 10:34:11 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:52 +0200
commit65557fd635f3815840a30750c5896d47bc008fd0 (patch)
tree9e81992b91661b6b646a5fdaee1cef7ee0ec9b41
parentfba705ef56b181a5f257173fcb09e4797f4c1e10 (diff)
gnu: Add texlive-pgfopts.
* gnu/packages/tex.scm (texlive-pgfopts): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 946828c9bd..3780c5ab89 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3225,6 +3225,30 @@ multiple physical pages, for example as for arranging pages to make
booklets.")
(license license:lppl1.3c)))
+(define-public texlive-pgfopts
+ (package
+ (name "texlive-pgfopts")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/pgfopts/" "source/latex/pgfopts/"
+ "tex/latex/pgfopts/")
+ (base32
+ "0p4bfqgkwmzhismrs7a10sblbgx4b6w259vdp1dd3hxvhc2kbnyn")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs (list texlive-pgf))
+ (home-page "https://ctan.org/pkg/pgfopts")
+ (synopsis "LaTeX package options with @code{pgfkeys}")
+ (description
+ "The @code{pgfkeys} package (part of the PGF distribution) is a way of
+defining and using large numbers of keys for key-value syntaxes. However,
+@code{pgfkeys} itself does not offer means of handling LaTeX class and package
+options. This package adds such option handling to @code{pgfkeys}, in the
+same way that @code{kvoptions} adds the same facility to the LaTeX standard
+@code{keyval} package.")
+ (license license:lppl1.3+)))
+
(define-public texlive-pgfornament
(package
(name "texlive-pgfornament")