summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2022-10-25 22:21:55 +0400
committerAndrew Tropin <andrew@trop.in>2022-10-25 22:39:15 +0400
commit6c5c464d55bedfda2698d88414bc10fc39b06553 (patch)
tree11fa14e39e2d5603ac957373d1a03117139f1f75
parenta0751e3250dfea7e52468c8090e18c3118d93a60 (diff)
gnu: emacs-git-gutter: Update to 0.92-0.ec28e85.
0.92 fails on recent emacs versions because of missing global-linum-mode. * gnu/packages/emacs-xyz.scm (emacs-git-gutter): Update to 0.92-0.ec28e85.
-rw-r--r--gnu/packages/emacs-xyz.scm38
1 files changed, 20 insertions, 18 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2d18d60cd2..596d1bd0a1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4862,30 +4862,32 @@ representation.")
(license license:gpl2+))))
(define-public emacs-git-gutter
- (package
- (name "emacs-git-gutter")
- (version "0.92")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/syohex/emacs-git-gutter")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1fkp6iyisb3g5afyjkxz4yj4ws5f8n7whklck4jdf3014vs01b3c"))))
- (build-system emacs-build-system)
- (home-page "https://github.com/syohex/emacs-git-gutter")
- (synopsis "See and manage hunks of text in a version control system")
- (description
- "This package is an Emacs minor mode for displaying and interacting with
+ (let ((commit "ec28e85d237065cb3c28db4b66d129da6d309f9c")
+ (revision "0"))
+ (package
+ (name "emacs-git-gutter")
+ (version (git-version "0.92" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/syohex/emacs-git-gutter")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fx3jp65ibcsv8akd8g4k701cs8yq0sg1bd2qszzfh6lvc4pblmi"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/syohex/emacs-git-gutter")
+ (synopsis "See and manage hunks of text in a version control system")
+ (description
+ "This package is an Emacs minor mode for displaying and interacting with
hunks of text managed in a version control system. Added modified and deleted
areas can be indicated with symbols on the edge of the buffer, and commands
can be used to move between and perform actions on these hunks.
Git, Mercurial, Subversion and Bazaar are supported, and many parts of the
display and behaviour is easily customisable.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-git-gutter-fringe
(let ((commit "648cb5b57faec55711803cdc9434e55a733c3eba")