summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 15:11:25 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:11 +0200
commit7b2efd144f763467c0fa2a8b37b957f286f937cb (patch)
tree210e19a04a825ab0de30033f006bfc9d33316390
parent160f78a4d92205df986ed9efcce7d3aac188cb24 (diff)
gnu: Add texlive-aastex.
* gnu/packages/tex.scm (texlive-aastex): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 78d65a4fe5..e227818a16 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1286,6 +1286,27 @@ a Marathi journal, with LaTeX.")
(license:fsf-free "file://doc/latex/aalok/README.txt")
license:fdl1.3+))))
+(define-public texlive-aastex
+ (package
+ (name "texlive-aastex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "bibtex/bst/aastex/" "doc/latex/aastex/"
+ "tex/latex/aastex/")
+ (base32
+ "07kbrv0vhlpdaxqkiwn2q4psldn5p2x5mmpaw70g6pgcbhk7r74h")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/aastex")
+ (synopsis "Macros for manuscript preparation for AAS journals")
+ (description
+ "The bundle provides a document class for preparing papers for
+@acronym{AAS, American Astronomical Society} publications. Authors who wish
+to submit papers to AAS journals are strongly urged to use this class in
+preference to any of the alternatives available.")
+ (license license:lppl1.3+)))
+
(define-public texlive-abc
(package
(name "texlive-abc")