summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 13:10:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:15 +0200
commit7e335b9ad20ad1aa8699e51d1d727a5120294f9d (patch)
tree37fceb9bfff35c4e2d002b41dbe9bdc729d1aaf8
parentbdd1c5396dc4143d81cb9968c56c8caaa5ac48c0 (diff)
gnu: Add texlive-causets.
* gnu/packages/tex.scm (texlive-causets): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ba87eab303..51b2f5d4a5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2158,6 +2158,26 @@ mechanism.
@end itemize")
(license license:lppl1.3+)))
+(define-public texlive-causets
+ (package
+ (name "texlive-causets")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/causets/" "tex/latex/causets/")
+ (base32
+ "03n3k1xklf42k8ybvvg0hlakqavcsa2dap8hpj3ln007yr4m22g8")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/causets")
+ (synopsis "Draw causal set (Hasse) diagrams")
+ (description
+ "This LaTeX package uses TikZ to generate (Hasse) diagrams for causal sets
+(causets) to be used inline with text or in mathematical expressions. The
+macros can also be used in the @code{tikzpicture} environment to annotate or
+modify a diagram.")
+ (license license:lppl1.3+)))
+
(define-public texlive-chronosys
(package
(name "texlive-chronosys")