summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 18:44:55 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:15 +0200
commit7e8066ecdbec43363a73915971a2a4d3f2fa94ea (patch)
tree5192faedbb1c927466f31ec9268e6d19c96babd8
parent934201ae474a973ccfa9324a342ab9e4f57cc269 (diff)
gnu: Add texlive-bib2gls.
* gnu/packages/tex.scm (texlive-bib2gls): New variable.
-rw-r--r--gnu/packages/tex.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7abf670f2d..b33a664e7f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3209,6 +3209,44 @@ transliteration.")
files.")
(license license:lppl)))
+(define-public texlive-bib2gls
+ (package
+ (name "texlive-bib2gls")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/bib2gls.1"
+ "doc/man/man1/bib2gls.man1.pdf"
+ "doc/man/man1/convertgls2bib.1"
+ "doc/man/man1/convertgls2bib.man1.pdf"
+ "doc/support/bib2gls/"
+ "scripts/bib2gls/"
+ "source/support/bib2gls/src/")
+ (base32
+ "11a3wvyg5anm9hkmlpb6yvls1bmhypyswj55q332ziac6hpi2wd5")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "bib2gls.sh" "convertgls2bib.sh")))
+ (propagated-inputs (list texlive-glossaries-extra))
+ (home-page "https://ctan.org/pkg/bib2gls")
+ (synopsis
+ "Convert @file{.bib} files to @file{glossaries-extra.sty} resource files")
+ (description
+ "This Java command line application may be used to extract glossary
+information stored in a @file{.bib} file and convert it into glossary entry
+definition commands. This application should be used with
+@file{glossaries-extra.sty}'s record package option. It performs two
+functions in one: it selects entries according to records found in the
+@file{.aux} file (similar to BibTeX), and hierarchically sorts entries and
+collates location lists (similar to MakeIndex or Xindy). The glossary entries
+can then be managed in a system such as JabRef, and only the entries that are
+actually required will be defined, reducing the resources required by TeX.
+
+The supplementary application @command{convertgls2bib} can be used to convert
+existing @file{.tex} files containing definitions (@code{\\newglossaryentry}
+etc.)#: to the @file{.bib} format required by @command{bib2gls}.")
+ (license license:gpl3+)))
+
(define-public texlive-bibleref
(package
(name "texlive-bibleref")