summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 13:00:19 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 17:03:08 +0200
commit8d81e0baf30a2bf88c75597494854936c2214fd8 (patch)
treede96672663595a7093e21b5fbc0e92abce73ffba
parent20933028998129a1289519a6bd73516cd822d005 (diff)
gnu: Add texlive-algorithmicx.
* gnu/packages/tex.scm (texlive-algorithmicx): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4ce109e852..77eb1bfe95 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1317,6 +1317,28 @@ or @samp{Function}; the name of these functions may be reused in the text or
in other algorithms.")
(license license:lppl)))
+(define-public texlive-algorithmicx
+ (package
+ (name "texlive-algorithmicx")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/algorithmicx/"
+ "tex/latex/algorithmicx/")
+ (base32
+ "0q0qkzc88479y5dqifnpfxhclk48gf1c4shxi1xhgqbvjp2gqgza")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/algorithmicx")
+ (synopsis "The algorithmic style you always wanted")
+ (description
+ "Algorithmicx provides a flexible, yet easy to use, way for inserting
+good looking pseudocode or source code in your papers. It has built in
+support for pseudocode, Pascal and C, and offers powerful means to create
+definitions for any programming language. The user can adapt a pseudocode
+style to his native language.")
+ (license license:lppl)))
+
(define-public texlive-apnum
(package
(name "texlive-apnum")