summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 19:40:13 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:16 +0200
commit991fb27cf1ec5e73c8f507ff1e92ca7f6575611e (patch)
tree87c1ff896762302840641e2bd8c815c43390fbff
parent385eae4804aa97ff7cd0b3ac001e1638461f0934 (diff)
gnu: Add texlive-bibcop.
* gnu/packages/tex.scm (texlive-bibcop): New variable.
-rw-r--r--gnu/packages/tex.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4e4e296415..8b5225f64e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3285,6 +3285,34 @@ The lists are created by @command{bibsort}. This program creates the
bibliography without using MakeIndex or BibTeX.")
(license license:gpl3+)))
+(define-public texlive-bibcop
+ (package
+ (name "texlive-bibcop")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/bibtex/bibcop/"
+ "doc/man/man1/bibcop.1"
+ "doc/man/man1/bibcop.man1.pdf"
+ "scripts/bibcop/"
+ "source/bibtex/bibcop/"
+ "tex/latex/bibcop/")
+ (base32
+ "0w8n51ksff3b4nfx0ggnh00jhsdh1zg25hijxmpsq0z0wgazai9b")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "bibcop.pl")))
+ (inputs (list perl))
+ (propagated-inputs (list texlive-iexec texlive-pgfopts))
+ (home-page "https://ctan.org/pkg/bibcop")
+ (synopsis "Style checker for .bib files")
+ (description
+ "This LaTeX package checks the quality of your @file{.bib} file and emits
+warning messages if any issues are found. For this, the TeX processor must be
+run with the @samp{--shell-escape} option. @command{bibcop} can also be used
+as a standalone command line tool.")
+ (license license:expat)))
+
(define-public texlive-bibleref
(package
(name "texlive-bibleref")