summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:15 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:27 +0200
commit9acb1a6cae500ebe3526872f9a6c26bcd015ab95 (patch)
tree3bc6b7cb5857422e9c3ae7c8524856bb005df44f
parent402278a23402bb13241e0f1c69d3285fe4c9f046 (diff)
gnu: Add trytond-authentication-sms.
* gnu/packages/tryton.scm (trytond-authentication-sms): New variable.
-rw-r--r--gnu/packages/tryton.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 71afda0774..cb81695412 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1410,6 +1410,29 @@ shows for each employee the total duration per day in the company and the
detail of the time of entrance and exit")
(license license:gpl3+)))
+(define-public trytond-authentication-sms
+ (package
+ (name "trytond-authentication-sms")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_authentication_sms" version))
+ (sha256
+ (base32 "1g46mimgjkz2lvh90p2ffmkfgwl7w03iqnvqlcghwpxk5vyxw3sj"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "authentication_sms"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)))
+ (home-page "https://docs.tryton.org/projects/modules-authentication-sms")
+ (synopsis "Tryton module to authenticate users via SMS")
+ (description "The @emph{Authentication SMS} Tryton module allows users to
+authenticate via SMS. It adds a new authentication method sms, which can be
+used in the list of authentications in the session section of the
+configuration file.")
+ (license license:gpl3+)))
+
(define-public trytond-company
(package
(name "trytond-company")