summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Paśnikowski <marek@marekpasnikowski.pl>2024-03-19 07:21:18 +0100
committerMarek Paśnikowski <marek@marekpasnikowski.pl>2024-03-19 07:21:18 +0100
commit9ca001d199f145d0acafab0f54c12949ee3c0964 (patch)
tree2c1d3ed89e5dabb1ab1438ef79cbce3fb8ea8dad
parent1fe01205d792a821027039b2ccfb3644b4ecbb09 (diff)
Break out komodo-wallet source definition from the package body
-rw-r--r--private/komodo/komodo.scm169
1 files changed, 85 insertions, 84 deletions
diff --git a/private/komodo/komodo.scm b/private/komodo/komodo.scm
index 557ed5a7be..c142bd0fbe 100644
--- a/private/komodo/komodo.scm
+++ b/private/komodo/komodo.scm
@@ -48,87 +48,88 @@
(build-path-jl777-coins "../build/_deps/jl777-coins-src")
(build-path-mm2 "../build/_deps/mm2-src")
(version "0.7.0-beta"))
- (package
- (name "komodo-wallet")
- (version version)
- (source
- (origin
- (uri
- (git-reference
- (url
- "https://github.com/KomodoPlatform/komodo-wallet-desktop")
- (commit version)))
- (method git-fetch)
- (hash
- (content-hash
- "148fxnhsvqpgfc6jmj7qzz5504k3yqvn1jxqkqdxqmk0ch0abpd7"))))
- (build-system qt-build-system)
- (arguments
- (list
- #:phases
- #~ (modify-phases
- %standard-phases
- (add-after
- 'unpack
- 'delete-vcpkg
- (lambda _
- (substitute*
- "CMakeLists.txt"
- (("include\\(vcpkg_prerequisites\\)")
- (string-append
- "\nfile(MAKE_DIRECTORY \"" #+ build-path-expected "\")\n"
- "file(MAKE_DIRECTORY \"" #+ build-path-jl777-coins "\")\n"
- "file(MAKE_DIRECTORY \"" #+ build-path-mm2 "\")\n"
- "file(COPY "
- #+ (origin
- (uri
- (git-reference
- (url
- "https://github.com/TartanLlama/expected")
- (commit "v1.1.0")
- (recursive? #t)))
- (method git-fetch)
- (hash
- (content-hash
- "17akrv80h0n4cfmxwvlvbb8ycqza7y3qqygjyphv95rrabqm9r02"))
- (file-name (git-file-name "libexpected" "1.1.0"))
- (patches
- (search-patches "libexpected-use-provided-catch2.patch")))
- "/ " " DESTINATION " #+ build-path-expected
- " NO_SOURCE_PERMISSIONS"
- " FOLLOW_SYMLINK_CHAIN)\n"
- "file(ARCHIVE_EXTRACT INPUT "
- #+ (origin
- (uri "https://github.com/KomodoPlatform/coins/archive/master.zip")
- (method url-fetch)
- (hash
- (content-hash
- "02nsggdpksi0fwhp6arzjlaay8zvkl1hwnkg67nm7yl4vimb5s25")))
- " DESTINATION " #+ build-path-jl777-coins " )\n"
- "file(COPY " #+ build-path-jl777-coins "/coins-master/ "
- "DESTINATION " #+ build-path-jl777-coins ")\n"
- "file(ARCHIVE_EXTRACT INPUT "
- #+ (origin
- (uri
- "https://sdk.devbuilds.komodo.earth/main/mm2_b0fd99e-linux-x86-64.zip")
- (method url-fetch)
- (hash
- (content-hash
- "1bn2sjcrp9ih44h3p96prnwg74aids7fgzcnlv3c68nan6y2lysi")))
- " DESTINATION " #+ build-path-mm2 " )\n"))))))
- #:configure-flags
- #~ (list "-Wno-dev" "-DFETCHCONTENT_FULLY_DISCONNECTED=ON")))
- (native-inputs
- (list
- boost cpprestsdk date doctest entt fmt git libsodium-komodo nlohmann-json
- openssl qtcharts qtdeclarative-5 qttools-5 qtsvg-5 qtwebengine-5
- range-v3 spdlog zlib))
- (synopsis "Komodo Wallet Desktop GUI")
- (description
- (string-append
- "Komodo Wallet is a secure wallet and non-custodial "
- "decentralized exchange rolled into one application. Store "
- "your coind, trade peer-to-peer with minimal fees and never "
- "give up control over your digital assets."))
- (license license:gpl2)
- (home-page "https://atomicdex.io/"))))
+ (let ((komodo-wallet-origin
+ (origin
+ (uri
+ (git-reference
+ (url
+ "https://github.com/KomodoPlatform/komodo-wallet-desktop")
+ (commit version)))
+ (method git-fetch)
+ (hash
+ (content-hash
+ "0pfkgas0xkixf99zqzyri80ksp89b7dw7hbcgpp60ni2cnchxk2n")))))
+ (package
+ (name "komodo-wallet")
+ (version version)
+ (source komodo-wallet-origin)
+ (build-system qt-build-system)
+ (arguments
+ (list
+ #:phases
+ #~ (modify-phases
+ %standard-phases
+ (add-after
+ 'unpack
+ 'delete-vcpkg
+ (lambda _
+ (substitute*
+ "CMakeLists.txt"
+ (("include\\(vcpkg_prerequisites\\)")
+ (string-append
+ "\nfile(MAKE_DIRECTORY \"" #+ build-path-expected "\")\n"
+ "file(MAKE_DIRECTORY \"" #+ build-path-jl777-coins "\")\n"
+ "file(MAKE_DIRECTORY \"" #+ build-path-mm2 "\")\n"
+ "file(COPY "
+ #+ (origin
+ (uri
+ (git-reference
+ (url
+ "https://github.com/TartanLlama/expected")
+ (commit "v1.1.0")
+ (recursive? #t)))
+ (method git-fetch)
+ (hash
+ (content-hash
+ "17akrv80h0n4cfmxwvlvbb8ycqza7y3qqygjyphv95rrabqm9r02"))
+ (file-name (git-file-name "libexpected" "1.1.0"))
+ (patches
+ (search-patches "libexpected-use-provided-catch2.patch")))
+ "/ " " DESTINATION " #+ build-path-expected
+ " NO_SOURCE_PERMISSIONS"
+ " FOLLOW_SYMLINK_CHAIN)\n"
+ "file(ARCHIVE_EXTRACT INPUT "
+ #+ (origin
+ (uri "https://github.com/KomodoPlatform/coins/archive/master.zip")
+ (method url-fetch)
+ (hash
+ (content-hash
+ "1icbd6f8nridzc93vz7hsr5dnkrf328zfsw6rrzifc7nvsr559w8")))
+ " DESTINATION " #+ build-path-jl777-coins " )\n"
+ "file(COPY " #+ build-path-jl777-coins "/coins-master/ "
+ "DESTINATION " #+ build-path-jl777-coins ")\n"
+ "file(ARCHIVE_EXTRACT INPUT "
+ #+ (origin
+ (uri
+ "https://sdk.devbuilds.komodo.earth/main/mm2_b0fd99e-linux-x86-64.zip")
+ (method url-fetch)
+ (hash
+ (content-hash
+ "1bn2sjcrp9ih44h3p96prnwg74aids7fgzcnlv3c68nan6y2lysi")))
+ " DESTINATION " #+ build-path-mm2 " )\n"))))))
+ #:configure-flags
+ #~ (list "-Wno-dev" "-DFETCHCONTENT_FULLY_DISCONNECTED=ON")))
+ (native-inputs
+ (list
+ boost cpprestsdk date doctest entt fmt git libsodium-komodo nlohmann-json
+ openssl qtcharts qtdeclarative-5 qttools-5 qtsvg-5 qtwebengine-5
+ range-v3 spdlog zlib))
+ (synopsis "Komodo Wallet Desktop GUI")
+ (description
+ (string-append
+ "Komodo Wallet is a secure wallet and non-custodial "
+ "decentralized exchange rolled into one application. Store "
+ "your coind, trade peer-to-peer with minimal fees and never "
+ "give up control over your digital assets."))
+ (license license:gpl2)
+ (home-page "https://atomicdex.io/")))))