summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 13:01:06 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 17:03:09 +0200
commita1535b8e4bc97f284aa58b75c07f84b2dd2a2369 (patch)
tree357a486ebd4adc2897499d7f964e74cae84a32ae
parentfd00c53977387ff3d110e39c3d024aea28a89439 (diff)
gnu: Add texlive-algxpar.
* gnu/packages/tex.scm (texlive-algxpar): New variable.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 90e2b61393..8071402d7a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1385,6 +1385,25 @@ parts of the code for highlighting differences. This package also has better
support for long code lines spanning several lines and improved comments.")
(license license:lppl1.3c)))
+(define-public texlive-algxpar
+ (package
+ (name "texlive-algxpar")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/algxpar/" "source/latex/algxpar/"
+ "tex/latex/algxpar/")
+ (base32
+ "1d4g8wl29k85x2liwab86fw1yvns68c4ms6v7mvviavcvml4d3mx")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/algxpar")
+ (synopsis "Support multiple lines pseudocode")
+ (description
+ "This package extends the package @code{algorithmicx} to support long
+text which spans over multiple lines.")
+ (license license:lppl1.3+)))
+
(define-public texlive-apnum
(package
(name "texlive-apnum")