summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:01 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:25 +0200
commita513f9d9a0b0590b7a96dcaa8d674a7d055e5545 (patch)
tree5ef11864e10401b54d7581a29b4b17a0e291934e
parent7ff3424721e29d817c39aec3d3a136d73a3050e8 (diff)
gnu: Add trytond-account-dunning-fee.
* gnu/packages/tryton.scm (trytond-account-dunning-fee): New variable.
-rw-r--r--gnu/packages/tryton.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index f204e6a1d2..476787c2ce 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -419,6 +419,31 @@ receivable move lines.")
emails.")
(license license:gpl3+)))
+(define-public trytond-account-dunning-fee
+ (package
+ (name "trytond-account-dunning-fee")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_account_dunning_fee" version))
+ (sha256
+ (base32 "1h8qlrdvpyyf36cdss5lv3qp4h4xs6kp3ybh9ci14mhwy0jyni75"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "account_dunning_fee"))
+ (native-inputs
+ `(,@%standard-trytond-native-inputs
+ ("trytond-account-dunning-letter" ,trytond-account-dunning-letter)))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-account-dunning" ,trytond-account-dunning)
+ ("trytond-account-product" ,trytond-account-product)))
+ (home-page "https://docs.tryton.org/projects/modules-account-dunning-fee")
+ (synopsis "Tryton module for account dunning fee")
+ (description "This package provides a Tryton module for generating
+accounting moves as fees when processing dunning.")
+ (license license:gpl3+)))
+
(define-public trytond-account-invoice
(package
(name "trytond-account-invoice")