summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 18:23:27 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:13 +0200
commitabfe35ebac42e5527b9a6babea08ba8e25a50887 (patch)
treefdd8d2b6d3dc81343e6e4b7dab785046b52e2385
parent83ec82298f0e5bc36e2c58267b8c7a037a0b7130 (diff)
gnu: Add texlive-annotate.
* gnu/packages/tex.scm (texlive-annotate): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7c16d3b7a0..bf6a30385c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1990,6 +1990,26 @@ of the academic year, a macro to be redefined to change the presentation of
the years.")
(license license:lppl1.3c)))
+(define-public texlive-annotate
+ (package
+ (name "texlive-annotate")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "bibtex/bst/annotate/")
+ (base32
+ "12q3xk08ycz57vsrcr2glk7y48w8sbc4n8lrqaicd46cxfd4jdqm")))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/annotate")
+ (synopsis "Bibliography style with annotations")
+ (description
+ "The style is a derivative of the standard @code{alpha} style, which
+processes an entry's annotate field as part of the printed output.")
+ ;; There is no explicit license in the "annotate.bst" file, but it
+ ;; mentions being derived from "alpha.bst", which is released under
+ ;; Knuth's terms. We therefore use the same license.
+ (license license:knuth)))
+
(define-public texlive-annotate-equations
(package
(name "texlive-annotate-equations")