summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-18 10:36:31 +0100
committerMarius Bakke <marius@gnu.org>2022-11-20 07:47:16 +0100
commitb1e802034d6896053f784a067d66d940a5897ae8 (patch)
tree28239effc96a68e4837a32be0f384832e878189e
parent915360ee9c4a8f948737267184918996fa271aa5 (diff)
gnu: libvpx: Update to 1.12.0.
* gnu/packages/video.scm (libvpx): Update to 1.12.0. (libvpx-next): Remove variable. * gnu/packages/jami.scm (ffmpeg-jami)[inputs]: Remove.
-rw-r--r--gnu/packages/jami.scm4
-rw-r--r--gnu/packages/video.scm20
2 files changed, 3 insertions, 21 deletions
diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
index 2c5a4c8d88..7e4fb04e0f 100644
--- a/gnu/packages/jami.scm
+++ b/gnu/packages/jami.scm
@@ -422,9 +422,7 @@
(substitute* "tests/fate/lavf-container.mak"
(("mov mov_rtphint ismv")
"mov ismv")
- (("fate-lavf-mov_rtphint:.*") ""))))))))
- (inputs (modify-inputs (package-inputs ffmpeg-5)
- (replace "libvpx" libvpx-next)))))
+ (("fate-lavf-mov_rtphint:.*") ""))))))))))
(define-public libjami
(package
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index f30f567206..19ca1d8267 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2367,7 +2367,7 @@ To load this plugin, specify the following option when starting mpv:
(define-public libvpx
(package
(name "libvpx")
- (version "1.11.0")
+ (version "1.12.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2376,7 +2376,7 @@ To load this plugin, specify the following option when starting mpv:
(file-name (git-file-name name version))
(sha256
(base32
- "00f1jrclai2b6ys78dpsg6r1mvcyxlna93vxcz8zjyia24c2pjsb"))
+ "1x12f2bd4jqd532rnixmwvcx8d29yxiacpcxqqh86qczc49la8gm"))
(patches (search-patches "libvpx-CVE-2016-2818.patch"))))
(build-system gnu-build-system)
(arguments
@@ -2406,22 +2406,6 @@ To load this plugin, specify the following option when starting mpv:
(license license:bsd-3)
(home-page "https://www.webmproject.org/")))
-;;; TODO: Merge into libvpx on staging.
-(define-public libvpx-next
- (package
- (inherit libvpx)
- (name "libvpx")
- (version "1.12.0")
- (source (origin
- (inherit (package-source libvpx))
- (uri (git-reference
- (url "https://chromium.googlesource.com/webm/libvpx")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1x12f2bd4jqd532rnixmwvcx8d29yxiacpcxqqh86qczc49la8gm"))))))
-
(define-public youtube-dl
(package
(name "youtube-dl")