summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 13:11:37 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:18 +0200
commitb47f26feb7d813d7156c5c86c3cb075f8b1942dd (patch)
treea5fee4c98499f69d3700967c2aef5a0938ff2cdd
parentda0b65e86f71b063078dd6eedacaf174282e5ceb (diff)
gnu: Add texlive-chemformula.
* gnu/packages/tex.scm (texlive-chemformula): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 426e719262..094b4f377b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2317,6 +2317,27 @@ the package supports the creation of exercise sheets, with separating printing
of solutions.")
(license license:lppl1.3+)))
+(define-public texlive-chemformula
+ (package
+ (name "texlive-chemformula")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/chemformula/"
+ "tex/latex/chemformula/")
+ (base32
+ "14w98hnhljfm62cxg2hml3razrxw9hkzm54v7ybnbhcp5mm7wvdm")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs (list texlive-units))
+ (home-page "https://ctan.org/pkg/chemformula")
+ (synopsis "Command for typesetting chemical formulas and reactions")
+ (description
+ "The package provides a command to typeset chemical formulas and
+reactions in support of other chemistry packages (such as
+@code{chemmacros}).")
+ (license license:lppl1.3c)))
+
(define-public texlive-chronosys
(package
(name "texlive-chronosys")