summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 15:26:24 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commitbc74e0e171f2df977e18b5623aed935f1b371bb8 (patch)
treebc12bdba5fe04d359233d4878206a6d40e0e79f7
parenta43a38a129e7f9aee3079bc8a73d6234c04ba432 (diff)
gnu: Add ghc-attoparsec.
* gnu/packages/haskell.scm (ghc-attoparsec): New variable.
-rw-r--r--gnu/packages/haskell.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 759d223a42..fa8b5cf752 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1134,6 +1134,34 @@ regex-posix, regex-pcre, regex-parsec, regex-tdfa, regex-dfa.")
@code{libtre} (fork by Roman Cheplyaka).")
(license bsd-3)))
+(define-public ghc-attoparsec
+ (package
+ (name "ghc-attoparsec")
+ (version "0.13.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/attoparsec/attoparsec-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0cprkr7bl4lrr80pz8mryb4rbfwdgpsrl7g0fbcaybhl8p5hm26f"))))
+ (build-system haskell-build-system)
+ (arguments `(#:tests? #f)) ; FIXME: ghc-test-framework unavailable
+ (propagated-inputs
+ `(("ghc-scientific" ,ghc-scientific)))
+ (inputs
+ `(("ghc-text" ,ghc-text)
+ ("ghc-vector" ,ghc-vector)))
+ (home-page "https://github.com/bos/attoparsec")
+ (synopsis "Fast combinator parsing for bytestrings and text")
+ (description "This library provides a fast parser combinator library,
+aimed particularly at dealing efficiently with network protocols and
+complicated text/binary file formats.")
+ (license bsd-3)))
+
(define-public ghc-appar
(package
(name "ghc-appar")