summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-05 14:05:29 +0200
committerMarius Bakke <marius@gnu.org>2022-09-08 21:40:00 +0200
commitcf76ab29c12229eb26fc006d9c412268d282f415 (patch)
tree7d758df7d83cbce259bda88dc6cd494539121f78
parentd541f11d129e2f00f9a51a9ab5adf4469808bf62 (diff)
gnu: iproute2: Update to 5.19.0.
* gnu/packages/linux.scm (iproute): Update to 5.19.0. [arguments]: Use G-expression. Add 'configure' phase. Remove patch-configure phase. Remove DOCDIR and DESTDIR from #:make-flags.
-rw-r--r--gnu/packages/linux.scm64
1 files changed, 31 insertions, 33 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ad6858cde7..fcabfbe73c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2703,7 +2703,7 @@ that the Ethernet protocol is much simpler than the IP protocol.")
(define-public iproute
(package
(name "iproute2")
- (version "5.15.0")
+ (version "5.19.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2711,40 +2711,38 @@ that the Ethernet protocol is much simpler than the IP protocol.")
version ".tar.xz"))
(sha256
(base32
- "1zwin8sjnnwf2a9rjwzb3q8lkhcpy06s29sh05f5gxd7z6jy9qrq"))))
+ "14bp7mlyb5dizrzhd5hh5m9aq6xn1jlwaf9b5sjgglkzd96s7dr6"))))
(build-system gnu-build-system)
(arguments
- `( ;; There is a test suite, but it wants network namespaces and sudo.
- #:tests? #f
- #:make-flags (let ((out (assoc-ref %outputs "out")))
- (list "DESTDIR="
- (string-append "CC=" ,(cc-for-target))
- "HOSTCC=gcc"
- (string-append "BASH_COMPDIR=" out
- "/etc/bash_completion.d")
- (string-append "LIBDIR=" out "/lib")
- (string-append "HDRDIR=" out "/include")
- (string-append "SBINDIR=" out "/sbin")
- (string-append "CONFDIR=" out "/etc")
- (string-append "DOCDIR=" out "/share/doc/"
- ,name "-" ,version)
- (string-append "MANDIR=" out "/share/man")))
- #:phases (modify-phases %standard-phases
- (add-before 'install 'pre-install
- (lambda _
- ;; Don't attempt to create /var/lib/arpd.
- (substitute* "Makefile"
- (("^.*ARPDDIR.*$") ""))
- #t))
- (add-after 'unpack 'patch-configure
- (lambda _
- (let ((target ,(%current-target-system)))
- (substitute* "configure"
- (("pkg-config")
- (if target
- (string-append target "-pkg-config")
- "pkg-config")))
- #t))))))
+ (list
+ ;; There is a test suite, but it wants network namespaces and sudo.
+ #:tests? #f
+ #:make-flags
+ #~(let ((out #$output))
+ (list (string-append "CC=" #$(cc-for-target))
+ "HOSTCC=gcc"
+ (string-append "BASH_COMPDIR=" out
+ "/etc/bash_completion.d")
+ (string-append "LIBDIR=" out "/lib")
+ (string-append "HDRDIR=" out "/include")
+ (string-append "SBINDIR=" out "/sbin")
+ (string-append "CONFDIR=" out "/etc")
+ (string-append "MANDIR=" out "/share/man")))
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key (configure-flags #~'()) #:allow-other-keys)
+ ;; The configure script does not understand some of the
+ ;; default options of gnu-build-system.
+ (setenv "PKG_CONFIG" #$(pkg-config-for-target))
+ (apply invoke "./configure"
+ "--prefix" #$output
+ configure-flags)))
+ (add-before 'install 'pre-install
+ (lambda _
+ ;; Don't attempt to create /var/lib/arpd.
+ (substitute* "Makefile"
+ (("^.*ARPDDIR.*$") "")))))))
(inputs
(list bdb iptables libmnl))
(native-inputs