summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-14 20:18:38 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-02 20:16:36 +0200
commitcf988f65f9079fabbb1cfb570e85eaca81757f35 (patch)
treebf77466660fd44aea5c891e842d4066c2c1a5405
parent33d04000a5dab24d29fd43d89ef3d0001a27eada (diff)
gnu: Add rust-opaque-debug-0.2.
* gnu/packages/crates-io.scm (rust-opaque-debug-0.2): New version. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f7b06457ad..91d96ca5a1 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -4425,6 +4425,27 @@ slices (@code{.find()}, @code{RevSlice}), strings and other things.
Things in odds may move to more appropriate crates if we find them.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-opaque-debug-0.2
+ (package
+ (name "rust-opaque-debug")
+ (version "0.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "opaque-debug" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "02942l2gc7w5r4js7i9063x99szic5mzzk1055j83v4diqpbpxck"))))
+ (build-system cargo-build-system)
+ (arguments `(#:skip-build? #t))
+ (home-page "https://github.com/RustCrypto/utils")
+ (synopsis "Macro for opaque Debug trait implementation")
+ (description
+ "Macro for opaque Debug trait implementation.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-openssl-0.10
(package
(name "rust-openssl")