summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Paśnikowski <marek@marekpasnikowski.pl>2024-03-19 09:39:08 +0100
committerMarek Paśnikowski <marek@marekpasnikowski.pl>2024-03-19 09:39:08 +0100
commitd13b9ef2eb7458f43a55eec83a2b510d3a9b63db (patch)
tree9f689e3a20649d8266bb0c8ace3a2160f4d32606
parent532f04ab2c082ee452c969f65fda9aa6bd3b3686 (diff)
Break out komodo-wallet phases of the arguments body
-rw-r--r--private/komodo/komodo.scm108
1 files changed, 53 insertions, 55 deletions
diff --git a/private/komodo/komodo.scm b/private/komodo/komodo.scm
index b9b72a59f6..ade5442868 100644
--- a/private/komodo/komodo.scm
+++ b/private/komodo/komodo.scm
@@ -48,62 +48,60 @@
(build-path-jl777-coins "../build/_deps/jl777-coins-src")
(build-path-mm2 "../build/_deps/mm2-src")
(version "0.7.0-beta"))
- (let ()
+ (let ((phases #~ (modify-phases
+ %standard-phases
+ (add-after
+ 'unpack
+ 'delete-vcpkg
+ (lambda _
+ (substitute*
+ "CMakeLists.txt"
+ (("include\\(vcpkg_prerequisites\\)")
+ (string-append
+ "\nfile(MAKE_DIRECTORY \"" #+ build-path-expected "\")\n"
+ "file(MAKE_DIRECTORY \"" #+ build-path-jl777-coins "\")\n"
+ "file(MAKE_DIRECTORY \"" #+ build-path-mm2 "\")\n"
+ "file(COPY "
+ #+ (origin
+ (uri
+ (git-reference
+ (url
+ "https://github.com/TartanLlama/expected")
+ (commit "v1.1.0")
+ (recursive? #t)))
+ (method git-fetch)
+ (hash
+ (content-hash
+ "17akrv80h0n4cfmxwvlvbb8ycqza7y3qqygjyphv95rrabqm9r02"))
+ (file-name (git-file-name "libexpected" "1.1.0"))
+ (patches
+ (search-patches "libexpected-use-provided-catch2.patch")))
+ "/ " " DESTINATION " #+ build-path-expected
+ " NO_SOURCE_PERMISSIONS"
+ " FOLLOW_SYMLINK_CHAIN)\n"
+ "file(ARCHIVE_EXTRACT INPUT "
+ #+ (origin
+ (uri "https://github.com/KomodoPlatform/coins/archive/master.zip")
+ (method url-fetch)
+ (hash
+ (content-hash
+ "1icbd6f8nridzc93vz7hsr5dnkrf328zfsw6rrzifc7nvsr559w8")))
+ " DESTINATION " #+ build-path-jl777-coins " )\n"
+ "file(COPY " #+ build-path-jl777-coins "/coins-master/ "
+ "DESTINATION " #+ build-path-jl777-coins ")\n"
+ "file(ARCHIVE_EXTRACT INPUT "
+ #+ (origin
+ (uri
+ "https://sdk.devbuilds.komodo.earth/main/mm2_b0fd99e-linux-x86-64.zip")
+ (method url-fetch)
+ (hash
+ (content-hash
+ "1bn2sjcrp9ih44h3p96prnwg74aids7fgzcnlv3c68nan6y2lysi")))
+ " DESTINATION " #+ build-path-mm2 " )\n"))))))))
(let ((komodo-wallet-arguments
- (list
- #:phases
- #~ (modify-phases
- %standard-phases
- (add-after
- 'unpack
- 'delete-vcpkg
- (lambda _
- (substitute*
- "CMakeLists.txt"
- (("include\\(vcpkg_prerequisites\\)")
- (string-append
- "\nfile(MAKE_DIRECTORY \"" #+ build-path-expected "\")\n"
- "file(MAKE_DIRECTORY \"" #+ build-path-jl777-coins "\")\n"
- "file(MAKE_DIRECTORY \"" #+ build-path-mm2 "\")\n"
- "file(COPY "
- #+ (origin
- (uri
- (git-reference
- (url
- "https://github.com/TartanLlama/expected")
- (commit "v1.1.0")
- (recursive? #t)))
- (method git-fetch)
- (hash
- (content-hash
- "17akrv80h0n4cfmxwvlvbb8ycqza7y3qqygjyphv95rrabqm9r02"))
- (file-name (git-file-name "libexpected" "1.1.0"))
- (patches
- (search-patches "libexpected-use-provided-catch2.patch")))
- "/ " " DESTINATION " #+ build-path-expected
- " NO_SOURCE_PERMISSIONS"
- " FOLLOW_SYMLINK_CHAIN)\n"
- "file(ARCHIVE_EXTRACT INPUT "
- #+ (origin
- (uri "https://github.com/KomodoPlatform/coins/archive/master.zip")
- (method url-fetch)
- (hash
- (content-hash
- "1icbd6f8nridzc93vz7hsr5dnkrf328zfsw6rrzifc7nvsr559w8")))
- " DESTINATION " #+ build-path-jl777-coins " )\n"
- "file(COPY " #+ build-path-jl777-coins "/coins-master/ "
- "DESTINATION " #+ build-path-jl777-coins ")\n"
- "file(ARCHIVE_EXTRACT INPUT "
- #+ (origin
- (uri
- "https://sdk.devbuilds.komodo.earth/main/mm2_b0fd99e-linux-x86-64.zip")
- (method url-fetch)
- (hash
- (content-hash
- "1bn2sjcrp9ih44h3p96prnwg74aids7fgzcnlv3c68nan6y2lysi")))
- " DESTINATION " #+ build-path-mm2 " )\n"))))))
- #:configure-flags
- #~ (list "-Wno-dev" "-DFETCHCONTENT_FULLY_DISCONNECTED=ON")))
+ (list #:phases phases
+ #:configure-flags
+ #~ (list "-Wno-dev" "-DFETCHCONTENT_FULLY_DISCONNECTED=ON")))
(komodo-wallet-description
(string-append
"Komodo Wallet is a secure wallet and non-custodial "