summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 13:05:45 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 17:12:56 +0200
commitf2e1a9cfcdb7786fd8015a04c4d515252e944fd1 (patch)
tree5a61f33012ca6c7845316ebcdb5c0ca9bdf0bd04
parentc81774bf4d340f640eedfe5787a1481c10ec3e1c (diff)
gnu: Add texlive-bitpattern.
* gnu/packages/tex.scm (texlive-bitpattern): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7e2dd45316..b6b3e39032 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1815,6 +1815,26 @@ out in a single macro call. A variant of the operation is provided, that
retains outer braces.")
(license license:lppl1.3+)))
+(define-public texlive-bitpattern
+ (package
+ (name "texlive-bitpattern")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/bitpattern/"
+ "source/latex/bitpattern/"
+ "tex/latex/bitpattern/")
+ (base32
+ "00f423jran7qqg9fwy3p7w1lhi20cxzlvn4hzsrz5pwd87bmvxxb")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/bitpattern")
+ (synopsis "Typeset bit pattern diagrams")
+ (description
+ "This package provides a package to typeset bit pattern diagrams such as those
+used to describe hardware, data format or protocols.")
+ (license license:lppl)))
+
(define-public texlive-borceux
(package
(name "texlive-borceux")