summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVessel Vave <vesselwave@disroot.org>2023-06-04 00:09:14 -0500
committerLudovic Courtès <ludo@gnu.org>2023-07-01 23:38:25 +0200
commitf9bb27b9b0c2198792408e1711e305d9abbc3764 (patch)
tree8e7a370653e63aab9adb50354e3244bc4079a46f
parentd6ca51d82ac04bfe88404184a1305172dc662e20 (diff)
gnu: Add swayfx.
* gnu/packages/wm.scm (swayfx): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/wm.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index c78a8786d6..4889b0becc 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -62,6 +62,7 @@
;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
;;; Copyright © 2023 Jonathan Brielamier <jonathan.brielmaier@web.de>
+;;; Copyright © 2023 Vessel Wave <vesselwave@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1687,6 +1688,29 @@ modules for building a Wayland compositor.")
(description "Sway is a i3-compatible Wayland compositor.")
(license license:expat)))
+(define-public swayfx
+ (package
+ (inherit sway)
+ (name "swayfx")
+ (version "0.3.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/WillPower3309/swayfx")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1550n9xnqbl1am4cwlnj8ip5cs7kgdzx96ga2hkcw29cpyian7rv"))))
+ (build-system meson-build-system)
+ (home-page "https://github.com/WillPower3309/swayfx")
+ (synopsis "Sway Fork with extra options and effects")
+ (description
+ "Fork of Sway, a Wayland compositor compatible with i3. SwayFX
+adds extra options and effects to the original Sway, such as blur, rounded
+corners, shadows, inactive window dimming, etc.")
+ (license license:expat)))
+
(define-public swayidle
(package
(name "swayidle")