summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 14:19:12 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commitfe8f53e39b05fd77876e4a9fbfac2d38136a5763 (patch)
tree735b9aa860282d14994a3365387b3b29d6610ae1
parentdc5befb126c0b861f2bfb512c0cf8e336f1c6a21 (diff)
gnu: Add ghc-http-types.
* gnu/packages/haskell.scm (ghc-http-types): New variable.
-rw-r--r--gnu/packages/haskell.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 5ef3afd7e7..9af661ae3f 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1024,6 +1024,35 @@ package. This package re-exports the unix package when available. When it
isn't available, portable implementations are used.")
(license bsd-3)))
+(define-public ghc-http-types
+ (package
+ (name "ghc-http-types")
+ (version "0.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/http-types/http-types-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0ny15jgm5skhs2yx6snr13lrnw19hwjgfygrpsmhib8wqa8cz8cc"))))
+ (build-system haskell-build-system)
+ (arguments `(#:tests? #f)) ; FIXME: Tests cannot find
+ ; Blaze.Bytestring.Builder, which should be
+ ; provided by ghc-blaze-builder.
+ (propagated-inputs
+ `(("ghc-case-insensitive" ,ghc-case-insensitive)
+ ("ghc-blaze-builder" ,ghc-blaze-builder)))
+ (inputs
+ `(("ghc-text" ,ghc-text)))
+ (home-page "https://github.com/aristidb/http-types")
+ (synopsis "Generic HTTP types for Haskell")
+ (description "This package provides generic HTTP types for Haskell (for
+both client and server code).")
+ (license bsd-3)))
+
(define-public ghc-iproute
(package
(name "ghc-iproute")