summaryrefslogtreecommitdiff
path: root/etc
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2024-01-07 21:27:27 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2024-01-07 21:27:27 -0500
commitd9dee5ea2f564fa6979ae552fd9bd5ac22f86ecc (patch)
tree8d1b2f89808f9e7ddbeddeab7563f3ab82e533cd /etc
parentef4e4c9a2ccc1678182fa6e4409fff13c669fd14 (diff)
parent3de361d9c9d320aefbd43710124d7b07af891de1 (diff)
Merge branch 'master' into mesa-updates
Change-Id: I0b92a95109688a1a4c50572bc25a4e5676e0921e
Diffstat (limited to 'etc')
-rwxr-xr-xetc/teams.scm20
-rw-r--r--etc/teams/rust/rust-manifest.scm34
2 files changed, 52 insertions, 2 deletions
diff --git a/etc/teams.scm b/etc/teams.scm
index fba9010130..98f51c13e1 100755
--- a/etc/teams.scm
+++ b/etc/teams.scm
@@ -310,7 +310,8 @@ asdf-build-system."
(define-team bootstrap
(team 'bootstrap
#:name "Bootstrap"
- #:scope (list "gnu/packages/mes.scm")))
+ #:scope (list "gnu/packages/commencement.scm"
+ "gnu/packages/mes.scm")))
(define-team embedded
(team 'embedded
@@ -424,6 +425,21 @@ asdf-build-system."
(make-regexp* "^guix/scripts/")
(make-regexp* "^guix/store/"))))
+(define-team core-packages
+ (team 'core-packages
+ #:name "Core packages"
+ #:description "Core packages: the GNU tool chain, Guile, Coreutils, etc."
+ #:scope (list "gnu/packages/base.scm"
+ "gnu/packages/bootstrap.scm"
+ "gnu/packages/commencement.scm"
+ "gnu/packages/cross-base.scm"
+ "gnu/packages/gcc.scm"
+ "gnu/packages/guile.scm"
+ "gnu/packages/make-bootstrap.scm"
+ "guix/build/gnu-build-system.scm"
+ "guix/build/utils.scm"
+ "guix/build-system/gnu.scm")))
+
(define-team games
(team 'games
#:name "Games and Toys"
@@ -556,7 +572,7 @@ GLib/GIO, GTK, GStreamer and Webkit."
(define-member (person "Ludovic Courtès"
"ludo@gnu.org")
- core home bootstrap installer mentors)
+ core home bootstrap core-packages installer mentors)
(define-member (person "Andreas Enge"
"andreas@enge.fr")
diff --git a/etc/teams/rust/rust-manifest.scm b/etc/teams/rust/rust-manifest.scm
new file mode 100644
index 0000000000..f34b7489ec
--- /dev/null
+++ b/etc/teams/rust/rust-manifest.scm
@@ -0,0 +1,34 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Efraim Flashner <efraim@flashner.co.il>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+;;; This file returns a manifest of packages built using the cargo-build-system.
+;;; It is used to assist continuous integration of the rust-team branch.
+
+(use-modules (guix packages)
+ (guix profiles)
+ (guix build-system))
+
+(manifest
+ (map package->manifest-entry
+ (fold-packages
+ (lambda (package lst)
+ (if (eq? (build-system-name (package-build-system package))
+ (quote cargo))
+ (cons package lst)
+ lst))
+ (list))))