summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-09-11 23:38:47 +0100
committerMathieu Othacehe <othacehe@gnu.org>2023-10-05 17:07:16 +0200
commit9917079bd708deed1e797a60eb549b1586d60962 (patch)
tree17a0a83ddd56a6551ceb6ea3694e8d606c3f634d /gnu/packages/astronomy.scm
parentd37e24827a332816335161a2595d8484f98c906d (diff)
gnu: Add WCSTools.
* gnu/packages/astronomy.scm (wcstools): New variable. * gnu/packages/patches/wcstools-extend-makefiles.patch: New file. * gnu/local.mk: Add it. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index f6b3e5202d..7c665cba4a 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -754,6 +754,39 @@ header.")
(base32 "1m3bx6gh5w3c7vvsqcki0x20mg8lilg13m0i8nh7za89w58dxy4w"))))
(properties '((hidden? . #t)))))
+(define-public wcstools
+ (package
+ (name "wcstools")
+ (version "3.9.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://tdc-www.harvard.edu/software/wcstools/wcstools-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "125hqzspvqrx6372smzsmxwg06ib2arjc5awnwnq53w1xdq6jpsj"))
+ (patches (search-patches "wcstools-extend-makefiles.patch"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ;No tests provided.
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "http://tdc-www.harvard.edu/software/wcstools/")
+ (synopsis "Handle the WCS of a FITS image")
+ (description
+ "WCSTools is a set of software utilities, written in C, which create,
+display and manipulate the world coordinate system of a FITS or IRAF image,
+using specific keywords in the image header which relate pixel position within
+the image to position on the sky. Auxillary programs search star catalogs and
+manipulate images.")
+ (license license:gpl2+)))
+
(define-public weightwatcher
(package
(name "weightwatcher")