summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2020-09-16 20:12:37 +0530
committerArun Isaac <arunisaac@systemreboot.net>2020-10-12 11:41:45 +0530
commit665f51d3fa25f98baa14e4b4258caacbd0c752cd (patch)
tree7c31c26191e10ca85a0a7e4daa5d362697705612 /gnu/packages/crates-io.scm
parent0da9cb0a40a89c983723fe05ec650e1320c6ad17 (diff)
gnu: Add rust-lock-api-0.4.
* gnu/packages/crates-io.scm (rust-lock-api-0.4): New variable. (rust-lock-api-0.3): Inherit from rust-lock-api-0.4.
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm35
1 files changed, 24 insertions, 11 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e7765fe727..ad367ae8fc 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -12211,19 +12211,18 @@ by inspecting the system for user preference.")
("rust-regex" ,rust-regex-1)
("rust-winapi" ,rust-winapi-0.3))))))
-(define-public rust-lock-api-0.3
+(define-public rust-lock-api-0.4
(package
(name "rust-lock-api")
- (version "0.3.4")
+ (version "0.4.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "lock_api" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0xgc5dzmajh0akbh5d6d7rj9mh5rzpk74pyrc946v2ixgakj9nn4"))))
+ "0716z2rs0kydmd1818kqp4641dfkqzr0rpbnrpxhabxylp2pq918"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -12231,12 +12230,26 @@ by inspecting the system for user preference.")
("rust-scopeguard" ,rust-scopeguard-1)
("rust-serde" ,rust-serde-1))))
(home-page "https://github.com/Amanieu/parking_lot")
- (synopsis
- "Wrappers to create fully-featured Mutex and RwLock types")
- (description
- "This package provides wrappers to create fully-featured @code{Mutex} and
-@code{RwLock} types. It is compatible with @code{no_std}.")
- (license (list license:expat license:asl2.0))))
+ (synopsis "Wrappers to create fully-featured Mutex and RwLock types")
+ (description "This package provides wrappers to create fully-featured
+@code{Mutex} and @code{RwLock} types. It is compatible with @code{no_std}.")
+ (license (list license:asl2.0 license:expat))))
+
+(define-public rust-lock-api-0.3
+ (package
+ (inherit rust-lock-api-0.4)
+ (name "rust-lock-api")
+ (version "0.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "lock_api" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0xgc5dzmajh0akbh5d6d7rj9mh5rzpk74pyrc946v2ixgakj9nn4"))))
+ (build-system cargo-build-system)))
(define-public rust-lock-api-0.2
(package