summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-26 00:31:05 +0200
committerMarius Bakke <marius@gnu.org>2022-07-27 12:31:25 +0200
commitda5fdb971038e09632b8bfd7a526d4ef206009bb (patch)
treebb5a08c5ee8008b1e717b1a2bffb3c8b2690716c /gnu/packages/crates-io.scm
parent5830332150ae26412b0bfba0bd6e6ea674087442 (diff)
gnu: rust-rctree: Add 0.4.
* gnu/packages/crates-io.scm (rust-rctree-0.4): New variable. (rust-rctree-0.3): Inherit from it.
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 18 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f889cf417c..e907f6cc6a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -48088,19 +48088,18 @@ Rust.")
(description "This package provides core APIs for Rayon.")
(license (list license:asl2.0 license:expat))))
-(define-public rust-rctree-0.3
+(define-public rust-rctree-0.4
(package
(name "rust-rctree")
- (version "0.3.3")
+ (version "0.4.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "rctree" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1a54z2b850albiqx9vw009p9xg363vqzh1ybkwb89zn8375jk7my"))))
+ "1s92472lniqn2c0b5ln8ssl014x0raiyzkk0hagrvsd6far2iq4s"))))
(build-system cargo-build-system)
(home-page "https://github.com/RazrFalcon/rctree")
(synopsis "DOM-like tree implemented using reference counting")
@@ -48108,6 +48107,20 @@ Rust.")
reference counting.")
(license license:expat)))
+(define-public rust-rctree-0.3
+ (package
+ (inherit rust-rctree-0.4)
+ (name "rust-rctree")
+ (version "0.3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rctree" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1a54z2b850albiqx9vw009p9xg363vqzh1ybkwb89zn8375jk7my"))))))
+
(define-public rust-rdrand-0.4
(package
(name "rust-rdrand")