summaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-12-28 01:02:47 +0100
committerMarius Bakke <marius@gnu.org>2022-12-28 01:02:47 +0100
commitec0fbb471dfc6f72796da9ebafbb0630daa91267 (patch)
tree3b42f3d0a6470d85fbb8421179634bb278883e4e /gnu/packages/file-systems.scm
parentf5ef7d34e4deecb80aff585c108b0a2ab1f33ce4 (diff)
parent0cb8f7125b19264b01962c1249c3df4c5ce85aa9 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm39
1 files changed, 37 insertions, 2 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 4b1c1cebe8..57a25a0d90 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -599,7 +599,7 @@ from the bcachefs-tools package. It is meant to be used in initrds.")
(define-public exfatprogs
(package
(name "exfatprogs")
- (version "1.1.3")
+ (version "1.2.0")
(source
(origin
(method git-fetch)
@@ -608,7 +608,7 @@ from the bcachefs-tools package. It is meant to be used in initrds.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "14lgwvbg6jibsdpzpcj484p9q4ixawyjxi9hw23w89c6870gglw9"))))
+ (base32 "02a6178brikg12wl80h9qgxyhpm6mly0jnml0rs9phb7lkbv9kzh"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -752,6 +752,41 @@ transaction log.
from the jfsutils package. It is meant to be used in initrds.")
(license (package-license jfsutils))))
+(define-public nilfs-utils
+ (package
+ (name "nilfs-utils")
+ (version "2.2.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://nilfs.sourceforge.io/download"
+ "/nilfs-utils-" version ".tar.bz2"))
+ (sha256
+ (base32 "15vsayvzr8nc29n939sz9ddq46vpn53rp8h8qv484h88qac3kxjx"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list "--enable-static=no")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'bootstrap 'force-bootstrap
+ (lambda _
+ (delete-file "configure")
+ (substitute* "configure.ac"
+ (("\\[/etc\\]") "[${prefix}/etc]")
+ (("\\[/sbin\\]") "[${prefix}/sbin]")))))))
+ (inputs
+ (list (list util-linux "lib")))
+ (native-inputs (list autoconf automake libtool))
+ (home-page "https://nilfs.sourceforge.io/")
+ (synopsis "Continuous Snapshotting Filesystem")
+ (description
+ "NILFS is a log-structured file system supporting versioning of the entire
+file system and continuous snapshotting, which allows users to even restore
+files mistakenly overwritten or destroyed just a few seconds ago.")
+ (license license:gpl3+)))
+
(define-public disorderfs
(package
(name "disorderfs")