summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 15:26:43 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit39505126b17dd3a19c215d95f828d81ee45ec454 (patch)
tree15aa6bf7e92c4fde1529266a98578d126e7b0953 /gnu/packages/haskell.scm
parentbc74e0e171f2df977e18b5623aed935f1b371bb8 (diff)
gnu: Add ghc-aeson.
* gnu/packages/haskell.scm (ghc-aeson): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index fa8b5cf752..33a603ccb1 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3152,4 +3152,40 @@ and space efficient. They are represented using
notation}.")
(license bsd-3)))
+(define-public ghc-aeson
+ (package
+ (name "ghc-aeson")
+ (version "0.10.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/aeson/aeson-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "19kp33rfivr4d3myyr8xn803wd7p8x5nc4wb3qvlgjwgyqjaxvrz"))))
+ (build-system haskell-build-system)
+ (arguments `(#:tests? #f)) ; FIXME: testing libraries are missing.
+ (propagated-inputs
+ `(("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-dlist" ,ghc-dlist)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-scientific" ,ghc-scientific)
+ ("ghc-syb" ,ghc-syb)
+ ("ghc-vector" ,ghc-vector)))
+ (inputs
+ `(("ghc-hashable" ,ghc-hashable)
+ ("ghc-text" ,ghc-text)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-quickcheck" ,ghc-quickcheck)))
+ (home-page "https://github.com/bos/aeson")
+ (synopsis "Fast JSON parsing and encoding")
+ (description "This package provides a JSON parsing and encoding library
+for Haskell, optimized for ease of use and high performance. (A note on
+naming: in Greek mythology, Aeson was the father of Jason.)")
+ (license bsd-3)))
+
;;; haskell.scm ends here