summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 14:38:27 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit9e5224e6f3d7604db3f75e70e69fdf187ec510f3 (patch)
tree9d06cb427ca30c396e742b0f2b4b1cb383281915 /gnu/packages/haskell.scm
parent624efe7304dfe9247d1078680cfe0b1704295526 (diff)
gnu: Add ghc-digest.
* gnu/packages/haskell.scm (ghc-digest): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index d606d48fbd..4a399ceb6d 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2456,6 +2456,33 @@ given term should not exist.")
in the @code{IO} monad, like @code{IORef}s or parts of the OpenGL state.")
(license bsd-3)))
+(define-public ghc-digest
+ (package
+ (name "ghc-digest")
+ (version "0.0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/digest/digest-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "04gy2zp8yzvv7j9bdfvmfzcz3sqyqa6rwslqcn4vyair2vmif5v4"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("zlib" ,zlib)))
+ (home-page
+ "http://hackage.haskell.org/package/digest")
+ (synopsis
+ "Various cryptographic hashes for bytestrings")
+ (description
+ "This package provides efficient cryptographic hash implementations for
+strict and lazy bytestrings. For now, CRC32 and Adler32 are supported; they
+are implemented as FFI bindings to efficient code from zlib.")
+ (license bsd-3)))
+
(define-public ghc-bifunctors
(package
(name "ghc-bifunctors")