summaryrefslogtreecommitdiff
path: root/gnu/packages/lua.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-11-26 11:12:59 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2023-11-26 11:12:59 -0500
commitd15ffea6f47a40a9d36f3f32935e63f92e90af03 (patch)
tree826b3be17acf0f680e7888b3f7a3eeeaaedded7d /gnu/packages/lua.scm
parent8d2a5a36af4c36dfa08c7ee75d7a06ebb7a8225a (diff)
parent176440c056fdde6da98b11720989b1ed060ec97c (diff)
Merge branch 'master' into mesa-updates
Change-Id: Ide02272218e76dfae6dc9f8748871c8d61704260
Diffstat (limited to 'gnu/packages/lua.scm')
-rw-r--r--gnu/packages/lua.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 65cab6511c..1cde6bd66c 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -1269,6 +1269,39 @@ simplicity, and reach of Lua with the flexibility of a Lisp syntax and macro
system.")
(license license:expat)))
+(define-public antifennel
+ (package
+ (version "0.2.0")
+ (name "antifennel")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~technomancy/antifennel")
+ (commit version)))
+ (sha256
+ (base32 "1hd9h17q31b3gg88c657zq4han4air2ag55rrakbmcpy6n8acsqc"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (inputs (list luajit))
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ ;; Tests pass after the fix introduced by the commit
+ ;; ecd2169fcad1fa6616fdf6e6a8569f5b866601e5
+ (delete 'check)
+ (replace 'install
+ (lambda _
+ (install-file "antifennel"
+ (string-append #$output "/bin")))))))
+ (home-page "https://git.sr.ht/~technomancy/antifennel")
+ (synopsis "Turn Lua code into Fennel code")
+ (description
+ "This package provides a way to turn Lua code into Fennel code.
+This compiler does the opposite of what the Fennel compiler does.")
+ (license license:expat)))
+
(define-public fnlfmt
(package
(name "fnlfmt")