summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2023-04-14 19:27:32 +0000
committerLudovic Courtès <ludo@gnu.org>2023-05-02 11:58:06 +0200
commitab7de7df994172d4df301b02428a96c341948ef9 (patch)
tree8f9d69c34e17ad2a1b7b2ec93b75aaf93500fc46 /gnu/packages/maths.scm
parentd85ffbe381ec857d4d6da3c4c9447ad66025a071 (diff)
gnu: dune-alugrid: Update to 2.9.0.
* gnu/packages/maths.scm (dune-alugrid): Update to 2.9.0. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm101
1 files changed, 49 insertions, 52 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index d33487c047..9ff2e7d788 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -7081,60 +7081,57 @@ assemble global function spaces on finite-element grids.")
(license license:gpl2)))
(define-public dune-alugrid
- ;; This was the last commit on the releases/2.7 branch as of 2021-12-17,
- ;; unfortunately there was no tag for any 2.7 release.
- (let ((commit "51bde29a2dfa7cfac4fb73d40ffd42b9c1eb1d3d"))
- (package
- (name "dune-alugrid")
- (version (git-version "2.7.1" "0" commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.dune-project.org/extensions/dune-alugrid.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0z16wg6llzxs7vjg2yilg31vwnkz8k050j6bspg3blbym0razy15"))))
- (build-system cmake-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-include
- (lambda _
- (substitute* "dune/alugrid/test/test-alugrid.cc"
- (("doc/grids/gridfactory/testgrids")
- "doc/dune-grid/grids/gridfactory/testgrids"))
- #t))
- (add-after 'build 'build-tests
- (lambda* (#:key inputs make-flags parallel-build? #:allow-other-keys)
- (setenv "CPLUS_INCLUDE_PATH"
- (string-append (assoc-ref inputs "dune-grid") "/share"))
- (apply invoke "make" "build_tests"
- `(,@(if parallel-build?
- `("-j" ,(number->string (parallel-job-count)))
- '())
- ,@make-flags)))))))
- (inputs
- (list dune-common
- dune-geometry
- dune-grid
- ;; Optional
- metis
- openblas
- python
- superlu
- gmp
- zlib))
- (native-inputs
- (list gfortran pkg-config))
- (home-page "https://dune-project.org/")
- (synopsis "Distributed and Unified Numerics Environment")
- (description "ALUGrid is an adaptive, loadbalancing, unstructured
+ (package
+ (name "dune-alugrid")
+ (version "2.9.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.dune-project.org/extensions/dune-alugrid.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0s41jinsfpm56nx41vkmyv3y9n072ssw9hxjm7di64zcszgpjmzd"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-include
+ (lambda _
+ (substitute* "dune/alugrid/test/test-alugrid.cc"
+ (("doc/grids/gridfactory/testgrids")
+ "doc/dune-grid/grids/gridfactory/testgrids"))
+ #t))
+ (add-after 'build 'build-tests
+ (lambda* (#:key inputs make-flags parallel-build? #:allow-other-keys)
+ (setenv "CPLUS_INCLUDE_PATH"
+ (string-append (assoc-ref inputs "dune-grid") "/share"))
+ (apply invoke "make" "build_tests"
+ `(,@(if parallel-build?
+ `("-j" ,(number->string (parallel-job-count)))
+ '())
+ ,@make-flags)))))))
+ (inputs
+ (list dune-common
+ dune-geometry
+ dune-grid
+ ;; Optional
+ metis
+ openblas
+ python
+ superlu
+ gmp
+ zlib))
+ (native-inputs
+ (list gfortran pkg-config))
+ (home-page "https://dune-project.org/")
+ (synopsis "Distributed and Unified Numerics Environment")
+ (description "ALUGrid is an adaptive, loadbalancing, unstructured
implementation of the DUNE grid interface supporting either simplices or
cubes.")
- (license license:gpl2+))))
+ (license license:gpl2+)))
(define-public dune-subgrid
;; This was the last commit on the releases/2.7 branch as of 2021-12-17.