summaryrefslogtreecommitdiff
path: root/gnu/packages/ntp.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-04-11 17:19:06 -0400
committerMark H Weaver <mhw@netris.org>2018-04-11 17:19:06 -0400
commit3c0316169b47a1c035390aae8a211dcbedc8f5f3 (patch)
tree3c89536e1ef0c1db4339175bce7ff64d2e42f591 /gnu/packages/ntp.scm
parentecfe88b76496c62fad4f6b6c593318378cebba22 (diff)
parent87a841b2d4b7f8bfd661ba2d2cd2bbce7f490fbd (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/ntp.scm')
-rw-r--r--gnu/packages/ntp.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index 28aabab740..e9ae9fa466 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
-;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
@@ -145,7 +145,18 @@ minimalist than ntpd.")
(file-name (string-append name "-" version "-checkout"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
+ `(;; Disable seccomp when it's not supported--e.g., on aarch64. See
+ ;; 'src/seccomp.c' for the list of supported systems.
+ #:configure-flags ,(if (any (lambda (system)
+ (string-contains (or
+ (%current-target-system)
+ (%current-system))
+ system))
+ '("x86_64" "i686" "arm"))
+ ''()
+ ''("--disable-seccomp-filter"))
+
+ #:phases (modify-phases %standard-phases
(add-after 'unpack 'autogen
(lambda _
;; The ancestor of 'SOURCE_DATE_EPOCH'; it contains the