summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/bitlbee-fix-tests.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-03-10 23:54:17 +0100
committerLudovic Courtès <ludo@gnu.org>2014-03-10 23:54:17 +0100
commite06f7865e2630494a522ac32b9c0a0311be3e1e2 (patch)
tree1a547ad3a2e4c1b98a67845a9de0dfc798227b5f /gnu/packages/patches/bitlbee-fix-tests.patch
parentff3c0c1b805453990a42f690f148b41b9dff382a (diff)
parentc9c88118a12b0e22b7369b1dc6b0e2f9db894986 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches/bitlbee-fix-tests.patch')
-rw-r--r--gnu/packages/patches/bitlbee-fix-tests.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/patches/bitlbee-fix-tests.patch b/gnu/packages/patches/bitlbee-fix-tests.patch
new file mode 100644
index 0000000000..52bb6c605d
--- /dev/null
+++ b/gnu/packages/patches/bitlbee-fix-tests.patch
@@ -0,0 +1,33 @@
+Pass the correct number of arguments to 'nick_strip' and 'nick_ok' in tests.
+
+Patch by Mark H Weaver <mhw@netris.org>.
+
+--- bitlbee/tests/check_nick.c.orig 2013-11-27 17:54:54.000000000 -0500
++++ bitlbee/tests/check_nick.c 2014-03-05 23:41:45.761230468 -0500
+@@ -30,7 +30,7 @@ START_TEST(test_nick_strip)
+ for (i = 0; get[i]; i++) {
+ char copy[60];
+ strcpy(copy, get[i]);
+- nick_strip(copy);
++ nick_strip(NULL, copy);
+ fail_unless (strcmp(copy, expected[i]) == 0,
+ "(%d) nick_strip broken: %s -> %s (expected: %s)",
+ i, get[i], copy, expected[i]);
+@@ -45,7 +45,7 @@ START_TEST(test_nick_ok_ok)
+ int i;
+
+ for (i = 0; nicks[i]; i++) {
+- fail_unless (nick_ok(nicks[i]) == 1,
++ fail_unless (nick_ok(NULL, nicks[i]) == 1,
+ "nick_ok() failed: %s", nicks[i]);
+ }
+ }
+@@ -58,7 +58,7 @@ START_TEST(test_nick_ok_notok)
+ int i;
+
+ for (i = 0; nicks[i]; i++) {
+- fail_unless (nick_ok(nicks[i]) == 0,
++ fail_unless (nick_ok(NULL, nicks[i]) == 0,
+ "nick_ok() succeeded for invalid: %s", nicks[i]);
+ }
+ }