summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libwmf-CVE-2007-2756.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-10-08 10:59:39 -0400
committerMark H Weaver <mhw@netris.org>2015-10-08 10:59:39 -0400
commitb81378251c629615aff0d62ca686bb53a10367de (patch)
tree4c15f2be58d665cf0eed1e00c84f70764890c3b8 /gnu/packages/patches/libwmf-CVE-2007-2756.patch
parent319fe79dd01e03c4ef61311c336bcd77e1133f02 (diff)
parentb5881775ac2db345bf5826d6351366346ff03275 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches/libwmf-CVE-2007-2756.patch')
-rw-r--r--gnu/packages/patches/libwmf-CVE-2007-2756.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/patches/libwmf-CVE-2007-2756.patch b/gnu/packages/patches/libwmf-CVE-2007-2756.patch
new file mode 100644
index 0000000000..feafac535a
--- /dev/null
+++ b/gnu/packages/patches/libwmf-CVE-2007-2756.patch
@@ -0,0 +1,20 @@
+Copied from Fedora.
+
+http://pkgs.fedoraproject.org/cgit/libwmf.git/tree/libwmf-0.2.8.4-CVE-2007-2756.patch
+
+--- libwmf-0.2.8.4/src/extra/gd/gd_png.c 1 Apr 2007 20:41:01 -0000 1.21.2.1
++++ libwmf-0.2.8.4/src/extra/gd/gd_png.c 16 May 2007 19:06:11 -0000
+@@ -78,8 +78,11 @@
+ gdPngReadData (png_structp png_ptr,
+ png_bytep data, png_size_t length)
+ {
+- gdGetBuf (data, length, (gdIOCtx *)
+- png_get_io_ptr (png_ptr));
++ int check;
++ check = gdGetBuf (data, length, (gdIOCtx *) png_get_io_ptr (png_ptr));
++ if (check != length) {
++ png_error(png_ptr, "Read Error: truncated data");
++ }
+ }
+
+ static void