summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python2-parameterized-docstring-test.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-21 22:39:42 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-21 22:39:42 +0100
commit8ed9be3faccb865204de46d2a8ed3e96e59281b6 (patch)
tree77ba4c90cda569048bc9ce2e414ede1567130c88 /gnu/packages/patches/python2-parameterized-docstring-test.patch
parent36930b2463fc933e7c5580f49413dbd14cf1df48 (diff)
parent715110a8a2e9e4b1a89635950744eb5260b8ee7f (diff)
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/patches/python2-parameterized-docstring-test.patch')
-rw-r--r--gnu/packages/patches/python2-parameterized-docstring-test.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/python2-parameterized-docstring-test.patch b/gnu/packages/patches/python2-parameterized-docstring-test.patch
new file mode 100644
index 0000000000..14691e1904
--- /dev/null
+++ b/gnu/packages/patches/python2-parameterized-docstring-test.patch
@@ -0,0 +1,18 @@
+Skip unicode docstring test, required when running on Python 2.
+
+See <https://github.com/wolever/parameterized/issues/44>.
+
+--- a/parameterized/test.py
++++ b/parameterized/test.py
+@@ -284,11 +284,6 @@
+ " More" %(foo, )
+ )
+
+- @parameterized.expand([param("foo")])
+- def test_unicode_docstring(self, foo):
+- u"""Döcumentation."""
+- self._assert_docstring(u"Döcumentation [with foo=%r]." %(foo, ))
+-
+ @parameterized.expand([param("foo", )])
+ def test_default_values_get_correct_value(self, foo, bar=12):
+ """Documentation"""