summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2023-12-30 11:36:37 +0100
committerMathieu Othacehe <othacehe@gnu.org>2024-01-09 10:19:43 +0100
commitdef734936f4dbe320f3102a0a646f0f478b0eaa6 (patch)
tree1b7a843134985d62b28907ca01a526f025d4bac3 /gnu/packages/python-xyz.scm
parent67c3d230dc10fdd270acc5a0334a538de06e9c50 (diff)
gnu: python-h5py: Enable tests.
* gnu/packages/python-xyz.scm (python-h5py)[native-inputs]: Add python-ipython and python-pytest. Change-Id: Ia1cae8bce802805c9d9b38a3bf515423f9b719b4 Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 99d9a79744..329b5f1b70 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2257,8 +2257,7 @@ library.")
"0pyr6z4h2xqbp49yx2i1401gl6yqh03h771zslwcy0201hpxiskg"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f ; no test target
- #:phases
+ '(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'fix-hdf5-paths
(lambda* (#:key inputs #:allow-other-keys)
@@ -2268,7 +2267,7 @@ library.")
(inputs
(list hdf5-1.10))
(native-inputs
- (list python-cython python-pkgconfig pkg-config))
+ (list python-cython python-ipython python-pkgconfig python-pytest pkg-config))
(home-page "https://www.h5py.org/")
(synopsis "Read and write HDF5 files from Python")
(description