summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-22 23:54:34 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-22 23:54:34 +0200
commitcdbd81ce144f17644ceebd3d08723aa244696a05 (patch)
treef2d4c484a5a8880fb32b81ac4330842c88a53e2a /gnu/packages/statistics.scm
parent10664c0f1c351eae24629127d97fe23f5e18a93c (diff)
parentec130e1a1b7f3b87b1a6e626754f7e7a07f6b717 (diff)
Merge branch 'master' into emacs-team
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm59
1 files changed, 30 insertions, 29 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index db99f4c7f2..d8fde36cd3 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -603,14 +603,14 @@ code for possible problems.")
(define-public r-foreign
(package
(name "r-foreign")
- (version "0.8-84")
+ (version "0.8-85")
(source
(origin
(method url-fetch)
(uri (cran-uri "foreign" version))
(sha256
(base32
- "0jc5r5wiqqbkni2xjdd24hic1xvfi151m9lnqhni52jnqw1g7v8p"))))
+ "1azca97fhwb1pzgrjw2xscfh2k7bfryp6wjsdcx2y4h7305d4ych"))))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/foreign")
(synopsis "Read data stored by other statistics software")
@@ -1005,13 +1005,13 @@ non-estimable cases correctly.")
(define-public r-labeling
(package
(name "r-labeling")
- (version "0.4.2")
+ (version "0.4.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "labeling" version))
(sha256
- (base32 "0rfikd9gy70b8qz87q9axcwv8nmn9mbxfdwypxi0sghpfs9df8p0"))))
+ (base32 "1wk4wa1s8f17b5lf8vs5hxsmyadp2ccmyg4hamq7sdvlrk14yby6"))))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/labeling")
(synopsis "Axis labeling algorithms")
@@ -1576,13 +1576,13 @@ emitter (http://pyyaml.org/wiki/LibYAML) for R.")
(define-public r-knitr
(package
(name "r-knitr")
- (version "1.43")
+ (version "1.44")
(source (origin
(method url-fetch)
(uri (cran-uri "knitr" version))
(sha256
(base32
- "0g6m9s53qyf34ba4db97k31sxg2ikndfp747229sm6ilikmbla9x"))))
+ "015ylljvx0q2himch4k813021nvh0l7p5x3aqdkj3w0ax8x8k3ki"))))
(build-system r-build-system)
(propagated-inputs
(list r-evaluate r-highr r-xfun r-yaml))
@@ -1827,13 +1827,13 @@ and printing capabilities than traditional data frames.")
(define-public r-dplyr
(package
(name "r-dplyr")
- (version "1.1.2")
+ (version "1.1.3")
(source (origin
(method url-fetch)
(uri (cran-uri "dplyr" version))
(sha256
(base32
- "1qwn00ai7k6km0z9kl6aa1qjkfz8j3prlgdfxr1pr5s47a5c6862"))))
+ "0hhpzv66rqz7z8vdryzjdkp4flmjvzxrx1pwpxnbmjqgvd3s4hv8"))))
(build-system r-build-system)
(propagated-inputs
(list r-cli
@@ -2963,13 +2963,13 @@ well as additional utilities such as panel and axis annotation functions.")
(define-public r-rcpparmadillo
(package
(name "r-rcpparmadillo")
- (version "0.12.6.1.0")
+ (version "0.12.6.4.0")
(source (origin
(method url-fetch)
(uri (cran-uri "RcppArmadillo" version))
(sha256
(base32
- "0saga8anaahyrvvynggg168756rv8d9gyq8sryjgnx5pp4jbz6ck"))))
+ "1k7xq2yl4pkc7krz1bcdnx5kfj6n4zjmnm40nly2da2ji87agv49"))))
(properties `((upstream-name . "RcppArmadillo")))
(build-system r-build-system)
(propagated-inputs
@@ -3837,13 +3837,13 @@ using the multicore functionality of the parallel package.")
extensions)))))
(package
(name "r-dt")
- (version "0.28")
+ (version "0.29")
(source (origin
(method url-fetch)
(uri (cran-uri "DT" version))
(sha256
(base32
- "0khdl21kvgi9k7dlpfshk1xz9bkly5lq6p41plfh4g2jv1yxaxfr"))
+ "1b9qshrjv9xaak92rvg65vkak4pyci9js4j7nkfcg0p19ghnvlm8"))
(modules '((guix build utils)
(ice-9 match)))
(snippet
@@ -3917,6 +3917,7 @@ using the multicore functionality of the parallel package.")
(list r-crosstalk
r-htmltools
r-htmlwidgets
+ r-httpuv
r-jquerylib
r-jsonlite
r-magrittr
@@ -4716,14 +4717,14 @@ distribution).")
(define-public r-rematch
(package
(name "r-rematch")
- (version "1.0.1")
+ (version "2.0.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "rematch" version))
(sha256
(base32
- "0y3mshvpvz9csmq8hk8jbabx4nxlv5sckvfzvm6920ndg34xw2d4"))))
+ "09jwg3glp32q4ml4khhzi8j7bzg9zhqqdg1m6r8gibh756zzgnhm"))))
(build-system r-build-system)
(home-page "https://github.com/MangoTheCat/rematch")
(synopsis "Match regular expressions with a nicer API")
@@ -4875,13 +4876,13 @@ package instead.")
(define-public r-hmisc
(package
(name "r-hmisc")
- (version "5.1-0")
+ (version "5.1-1")
(source
(origin
(method url-fetch)
(uri (cran-uri "Hmisc" version))
(sha256
- (base32 "0y10hnglid78gnaapmdy3ihjih4i2kvaycn2c60r2wr43nv7wl0q"))))
+ (base32 "0laan26ja6m9k3spkk1ymalwb181ramzjq6ii3b0404xv2kfywa9"))))
(properties `((upstream-name . "Hmisc")))
(build-system r-build-system)
(native-inputs
@@ -4896,9 +4897,9 @@ package instead.")
r-ggplot2
r-gridextra
r-gtable
- r-knitr
r-htmltable
r-htmltools
+ r-knitr
r-nnet
r-rmarkdown
r-rpart
@@ -5585,14 +5586,14 @@ data for species delimitation, nearest neighbor based noise detection.")
(define-public r-deoptimr
(package
(name "r-deoptimr")
- (version "1.1-1")
+ (version "1.1-2")
(source
(origin
(method url-fetch)
(uri (cran-uri "DEoptimR" version))
(sha256
(base32
- "1appp5xgayafda6f5pcdsxaskqs831rb21znx44r8nyb9gvg0f6z"))))
+ "0swycypiyxkvhn1438q0wysz2c4ky6zjw89w62dggbciqwk8xdbq"))))
(properties `((upstream-name . "DEoptimR")))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/DEoptimR")
@@ -5825,18 +5826,18 @@ showing the progress is useful e.g. bootstrap.")
(define-public r-minqa
(package
(name "r-minqa")
- (version "1.2.5")
+ (version "1.2.6")
(source
(origin
(method url-fetch)
(uri (cran-uri "minqa" version))
(sha256
(base32
- "1gpli7f3piz3jqjj63a6bk9v1jlygjdaqqqvqsr083crj0imd0wv"))))
+ "0421b4ysslaqmdgwlz080abis8m4xkcvjq7lx1wywbsz1s2vi9si"))))
(build-system r-build-system)
(propagated-inputs
(list r-rcpp))
- (inputs
+ (native-inputs
(list gfortran))
(home-page "https://optimizer.r-forge.r-project.org")
(synopsis "Derivative-free optimization algorithms by quadratic approximation")
@@ -7231,13 +7232,13 @@ Annealing\" @url{doi:10.1145/3025453.3025912}.")
(define-public r-lmom
(package
(name "r-lmom")
- (version "2.9")
+ (version "3.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "lmom" version))
(sha256
- (base32 "145va4dhl767mywk36xcmqilm21sfkqhcqi0s07qgq3k39sn4gin"))))
+ (base32 "1482kbb4cm65m2d1xlxml93yjd3d43iiap6nvzg5vd33i9iyh2jb"))))
(properties `((upstream-name . "lmom")))
(build-system r-build-system)
(native-inputs (list gfortran))
@@ -7315,13 +7316,13 @@ Calculates confidence intervals for the difference in proportion.")
(define-public r-desctools
(package
(name "r-desctools")
- (version "0.99.49")
+ (version "0.99.50")
(source
(origin
(method url-fetch)
(uri (cran-uri "DescTools" version))
(sha256
- (base32 "0s2zh8xz06c45rbwcypgsa8shby66nm6sj90cb9d1bwb60mws8j5"))))
+ (base32 "1awfhbv7klvkwxki4lvxj086yiwqyys95jnss8q5qqn7wyfz170v"))))
(properties `((upstream-name . "DescTools")))
(build-system r-build-system)
(propagated-inputs
@@ -7552,16 +7553,16 @@ generating and manipulating colors in R.")
(define-public r-reghelper
(package
(name "r-reghelper")
- (version "1.1.1")
+ (version "1.1.2")
(source (origin
(method url-fetch)
(uri (cran-uri "reghelper" version))
(sha256
(base32
- "0v1987rs6kcpizfhrp3hxsyx9arn5vsbapjfgj9478j73mm844ji"))))
+ "1vd8kd719kyjp65zym6zx3vax1q2kbhpl6la71d5aa59s54ylri3"))))
(properties `((upstream-name . "reghelper")))
(build-system r-build-system)
- (propagated-inputs (list r-ggplot2 r-lme4 r-mass r-nlme))
+ (propagated-inputs (list r-ggplot2 r-lme4 r-mass r-nlme r-rlang))
(home-page "https://github.com/jeff-hughes/reghelper")
(synopsis "Helper Functions for Regression Analysis")
(description