summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 15:46:34 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:34 +0200
commit0106ede60794b0c76a4d368dd81b30620974a902 (patch)
tree11aa7fad4d011b082a299fc852bd8a0d7a9326ec /gnu/packages/tex.scm
parentcccecd2257cc471af9eb451803e8cc87ec7bb510 (diff)
gnu: Add texlive-hfutthesis.
* gnu/packages/tex.scm (texlive-hfutthesis): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a8cd185c77..84fd7197be 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16288,6 +16288,29 @@ with guillemets, and support for character protruding using the
Technology (China).")
(license license:lppl1.3c)))
+(define-public texlive-hfutthesis
+ (package
+ (name "texlive-hfutthesis")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/xelatex/hfutthesis/"
+ "tex/xelatex/hfutthesis/")
+ (base32
+ "1i7ljf5521f9dynrcnim0m4jzz2qkvpsb4pjvxbj5c7pr85gc34r")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/hfutthesis")
+ (synopsis "LaTeX thesis template for Hefei University of Technology")
+ (description
+ "This project is based on the HFUT_Thesis LaTeX template of Hefei
+University of Technology compiled on the basis of @code{ustctug} and
+@code{ustcthesis}, in accordance with the latest version of @emph{Hefei
+University of Technology Graduate Dissertation Writing Specifications} and
+@emph{Hefei University of Technology Undergraduate Graduation Project (Thesis)
+Work Implementation Rules}.")
+ (license license:lppl1.3c)))
+
(define-public texlive-hindmadurai
(package
(name "texlive-hindmadurai")